Newbie setup ?'s about different firmwares

Discussion in 'R4 DS' started by hiver, Oct 5, 2012.

Oct 5, 2012
  1. hiver
    OP

    Newcomer hiver Member

    Joined:
    Nov 15, 2009
    Messages:
    46
    Country:
    United States
    Okay so I went with a purchase of a R4i Gold 3DS card
    However please please tell me from what I see and from research its seems compatible with my DSi XL !

    Just wondering with all these new firmware updates , which one do I get ?
    Do i install this 3DS wood update onto a micro sd card ?
    **(Even thou I don't own a 3DS model and will be only using a DSi XL ?)
    which files should I grab and put on the card from the makers website r4ids - if using it for USA (U) Dsi XL game play ?
    What's the patch and whats the kernal ? Do I add both to the SD card ?
    Not intrested in any additional MODS like video or SNES or GBA game playback

    Also there's this chart I found on this website - http://gbatemp.net/t290097-which-flash-cart-should-i-get
    What in the world is the difference between a Dsi (DS games) and a Dsi Games ??
    I ask because the chart shows no card has support for Dsi Games ?
    Wondering what that is all about ?

    I know there's a lot of ?'s asked but the answes must just be a few lines of response,
    Please help me out so I know exactly what I should be doing
    Thanks so very much for responses
     
  2. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    http://gbatemp.net/topic/278137-dsdsi3ds-hacking-faq/
    It's not just the 3DS, the DSi and DSi XL also have firmware updates, so you'll want to put the latest firmware update for the R4i Gold onto the MicroSD and run it (after putting Wood on the cart too).

    That's right, the cart has no support for DSi games. In fact the ONLY cart that runs DSi games is the iEvo, but it's not even supported anymore. That said, DSi-only games are very rare, and generally involve cute girl picture hair makeup stuff (using the DSi's camera) that most people here don't give two shits about anyways. The vast majority of games are DS-compatible games (that is, they will run on a DS/Lite) and will run on a flash cart.
     
  3. hiver
    OP

    Newcomer hiver Member

    Joined:
    Nov 15, 2009
    Messages:
    46
    Country:
    United States
    good stuff thanks for reply and now I understand what a Dsi game is thanks for clearing that up I was so confused

    So from my understanding
    I format my micro sd card
    then I dont need the latest firmware because that is only for a 3DS system
    so I would go with the WOOD R4 V1.52 Released. (2012-09-20) which is a kernal ?
    then i still need a patch ? or whats the patch ?

    Thanks for the help
     
  4. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Well the latest firmware also compounds on the DSi/XL update blocking, so you should run the update anyway. But yes you'd need to put Wood on there (the kernel/software) before you can run things.

    The 3DS compatibility/firmware update is a patch.
     
  5. hiver
    OP

    Newcomer hiver Member

    Joined:
    Nov 15, 2009
    Messages:
    46
    Country:
    United States
    My current firmware on my DSi XL is Ver 1.4.1 U
    so all I need is that Kernal installed
    no patch required right ?
     
  6. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    If the cart you're getting is brand new, then yes you won't need to patch, but it's recommended you run it anyways because if the DSi updates past what the cart supports, the cart will not run on that DS anymore and you will need to borrow somebody else's DS unit that the cart runs on in order to update it.

    It's better to update it now just in case. The DSi will want to update before going online, etc.
     

Share This Page