Network Controller Not Working!

Discussion in 'Computer Games and General Discussion' started by Rock Raiyu, Feb 14, 2009.

Feb 14, 2009
  1. Rock Raiyu
    OP

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    I needed to reformat after my drive got corrupted and I reinstalled Vista, but some of my drivers aren't working on my XPS M1530. Can someone help me? Thanks!
     
  2. Joe88

    Member Joe88 [λ]

    Joined:
    Jan 6, 2008
    Messages:
    11,189
    Location:
    NYC
    Country:
    United States
  3. Rock Raiyu
    OP

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    No, I mean, I have the disc with the drivers. But my it says my Network Controller drivers aren't installed even though I have installed everything thats on the disc but it doesn't work and I can't connect to the internet through it.
     
  4. Jiggah

    Member Jiggah GBAtemp Maniac

    Joined:
    Nov 9, 2002
    Messages:
    1,223
    Country:
    United States
    Go to Start > Control Panel > System and Maintence (or System on Classic View) > Device Manager

    Look to see if you see an yellow exclamation points. If you do then you can right click it and go to update drivers and manually select the driver if it didn't automatically install by itself.

    On another note, you should grab the drivers from the website rather than rely on the disc. The drivers on the disc are old.
     
  5. Rock Raiyu
    OP

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    Yeah, I took both of your advice and I got it to work. Thanks guys.

    And woop, 2000th post! [​IMG]
     

Share This Page