Need help with homebrew

Discussion in '3DS - Flashcards & Custom Firmwares' started by Lovepreet, Aug 15, 2016.

  1. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    https://github.com/Plailect/Guide/wiki/Part-5-(arm9loaderhax)

    I just finished
    Section II - Installing arm9loaderhax.
    ^ The screen was glitched for me so I pressed select and it booted to black screen.

    I booted my 2DS after making copies of the file in step 6.

    Now when I boot the 2DS normally it says "An old unsupported FIRM has been detected. Copy firmware.bin in /luma to boot."

    Please help I tried googling and I found nothing.
     


  2. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Exactly as it said somewhere (I believe part 5) you can find the firmware.bin. Just drag it to the luma folder on the root of your sd card! :D
     
  3. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    Where is the firmware.bin? Do I have to download it from somewhere?
     
  4. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Like I said it can be found as a download in a part of the guide. I believe Part 5
     
  5. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    I don't know if i'm blind or what, but I don't see anything for firmware.bin after crtl+ f search.
     
  6. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    It's on that website somewhere not necessarily in Part 5 though
     
  7. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada

    https://github.com/AuroraWright/Lum...-downgraded-from-the-gateway-menu-in-the-past

    I get a black screen on boot with an Old 3DS which has been downgraded from the Gateway menu in the past

    If your Old 3DS/Old 3DS XL has been downgraded to 4.5 from the Gateway menu in the past, your CTRNAND has leftovers from one or more previous FIRMs, and this causes issues with the CTRNAND code. This is not an issue with Luma itself, but rather with the GW downgrade process which doesn't do any cleanup and leaves CTRNAND in a messy state. Thankfully there's a method for cleaning your CTRNAND (at least the parts required by Luma3DS to operate normally):

    1. Get the NTR FIRMs package from here and the NAND FIRMs package from here
    2. Copy the O3DS firmware.bin file from the NTR FIRMs package to the luma folder


    I found a firmware.bin on the troubleshooting section. Is this the right firmware.bin? The 03DS firmware?
     
  8. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Yes it should be, just test it out can't harm you in anyway!
     
  9. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    Thank you it worked! Now I'm configuring Luma but I don't see these options to check off:

    • "SysNAND is updated"
    • "Force A9LH detection"

    Did i do something wrong?
     
    TheVinAnator likes this.
  10. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    You are only on secton 2 you do not need to check them off yet :P
     
  11. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    So, I still need to install rm9loaderhax?
     
  12. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    You said you are only on section II correct? There is V (5) sections with you being on II (2)! So yes it technically is not installed intall section 5!
     
  13. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    I'm actually on the final part. I'm on Part 5 SECTION 2.
     
  14. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Oh, well no you still don't need to check it yet!

    — Posts automatically merged - Please don't double post! —

    You check it on SECTION 3, are you saying there is no option?
     
  15. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    Yeah, there is no option. And if I select only 3 and reboot the 3DS just shows a black screen and fails to turn on properly.
     
  16. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Try re downloading the latest version of luma. It could also be the firmware.bin
     
  17. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    Should I download the normal luma 3ds? Thats what i used last time.

    OR should i use the .dev version?
     
  18. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Normal
     
  19. Lovepreet
    OP

    Lovepreet Member

    Newcomer
    46
    2
    May 5, 2010
    Canada
    Copy arm9loaderhax.bin and the luma folder from the Luma3DS zip to the root of your SD card

    I don't see a 'luma folder' in the zip file.

    There are 3 folders in the zip file 3ds, menuhax, pathchanger.

    Should I copy all 3 into my SD or one specific one?

    Anyone help please.
     
    Last edited by Lovepreet, Aug 15, 2016
  20. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,087
    5,165
    Mar 17, 2010
    Norway
    Alola
    According to the guide:
    SysNAND is updated (A9LH-only)" has been renamed to "Use SysNAND FIRM if booting with R (A9LH)"
    As for "Force A9LH detection" I am not sure, but it's not important. The option is only useful if you launch Luma from HBL, something you will probably never do, as you boot into Luma automatically on boot and you would need a 9.0-9.2 firmware to load it from HBL.
    The luma folder is no longer included as it's created automatically when the configuration is saved the first time (it was just a folder with an empty "payloads" folder inside it)
    I don't think you need any of those folders.
     
    Last edited by The Real Jdbye, Aug 15, 2016
    Lovepreet likes this.