Need Help Downgrading Browser

Discussion in '3DS - Flashcards & Custom Firmwares' started by MarioMasta64, Mar 14, 2017.

  1. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    when installing 0004003020009402 v2051 (n3ds internet browser -24)
    Failed to install CIA file
    Result code: 0xD8E0806A
    Level: Permanent (27)
    Summary: Invalid Argument (7)
    Module: AM (32)
    Desc: Cert signature or hash failed (106)

    im using the cia version of fbi and im on firmware 11.2
     
  2. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,153
    342
    Jun 4, 2010
    Venezuela
    Venezuela
    You didn't need to make another thread, you could have gone on on the other one...

    Err... are you sure the .cia was packaged well with 3Dnus?
    It is possible that it's failing on the signature part because it's lower than the minimum version list on 11.0+... i.e. trying to downgrade from arm11 would fail because even if you uninstalled the previous title when you get to the part of installing the lower version one the 3ds would realize it's lower than the minimum ver. and abort.
    But there's no official list of the error codes that FBI produces and their meaning/solution that i know of.
     
    Last edited by Alex658, Mar 14, 2017
  3. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    ah. i see. so if i replace the version list on 3ds with that of 9.2 or such ill be able to downgrade internet. (theories intensify)
     
  4. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,153
    342
    Jun 4, 2010
    Venezuela
    Venezuela
    The version list is on NATIVE_FIRM/FIRM Version(?) i believe, but honestly you shouldn't mess with that.
    Again, why is it that you need to stay on 11.2 and get the franken firm browser?
    The user @Ryccardo has been successful in franken-firmwaring his console and keep it working, it may be wise to ask him to help you in this case.

    According to this your CIA should be invalid or not signed.
     
    Last edited by Alex658, Mar 14, 2017
  5. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    because i cant connect to public hotspots :/ and yea. and native_firm is alot more than just the browser right? @Ryccardo wann help me?
     
  6. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,906
    2,235
    Jan 11, 2016
    Japan
    日本
    May I ask, why are you wanting to downgrade the browser?
     
  7. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    post above you.
     
  8. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    Yeah, if you are running a cfw (with sigpatches enabled) "invalid signature" means corrupt title

    Where did you get it from? Remember that Nintendo removes old browsers/Home/kernels from their servers!

    It's not a problem with the minimum version, since (your cfw may be patching that and) it would cause error D8E08027
     
    MarioMasta64 likes this.
  9. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    i have 11.2 also i got it from NUS. so essentially i want it from somewhere besides NUS?

    — Posts automatically merged - Please don't double post! —

    would you know any other way than nus to get a 9.6 n3ds browser?
     
  10. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    Check if there's a 9.6 downgrade pack on the iso site (or just get the 9.2 version that's probably a lot easier to find, not like they ever really improved anything)
     
    MarioMasta64 likes this.
  11. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    9.6 brought an improvement i really like (forgot which) and id rather not downgrade ^^"
     
  12. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    Just install the browser of course, not all the system titles :)
     
  13. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    so they come in .cia form?
     
  14. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    Yes, a cia for every system title
     
  15. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    noice ill check that out then (tho im kinda wary of the site since theirs anti-pirates their. what if they think im a pirate lol.)
     
  16. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    how do i tell if its n3ds or not?
     
  17. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    The zips have (New) in the name, and the N3DS browser has a different titleid from the O3DS one anyway
     
  18. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    cant find it...

    — Posts automatically merged - Please don't double post! —

    name of zip maybe?
     
  19. NintendoGamer28

    NintendoGamer28 GBAtemp Regular

    Member
    110
    25
    Jan 15, 2017
    I have a feeling you don't have custom firmware and you're using the maki edition if so it will not work
     
  20. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,963
    415
    Dec 21, 2016
    United States
    im using the latest hourly build of Luma as of 3/15/17 (today) are you able to help?

    — Posts automatically merged - Please don't double post! —

    i even documented my whole install process on twitter :D

    — Posts automatically merged - Please don't double post! —

    and if i didnt have cfw i wouldnt be able to use the .cia version of fbi or restore my 3ds back to 11.2

    — Posts automatically merged - Please don't double post! —

    also it took awhiole but i looked fbi maki edition. and well ._. why would i say i have cfw and that im using the .cia version of fbi if i was using that glitchy mess that is maki.