NDSi XL

Discussion in 'NDS - Flashcarts and Accessories' started by Bloodgod, May 30, 2010.

May 30, 2010

NDSi XL by Bloodgod at 8:38 AM (1,350 Views / 0 Likes) 7 replies

  1. Bloodgod
    OP

    Member Bloodgod 嵐の王

    Joined:
    Mar 25, 2007
    Messages:
    806
    Country:
    United States
    I'm thinking of gettin an XL. Do flash carts work on those yet?
     
  2. Beats

    Banned Beats Banned

    Joined:
    Apr 20, 2010
    Messages:
    267
    Location:
    ಠ_ಠ
    Country:
    Australia
    Sure they do.
     
  3. Crimsonclaw111

    Member Crimsonclaw111 GBAtemp Fan

    Joined:
    Apr 7, 2010
    Messages:
    387
    Country:
    United States
    Any DSi compatible cart will run on a NDSi XL, provided the firmware isn't 1.4 or the card is flashed.
     
  4. BoxShot

    Member BoxShot Chiyo-chan :3

    Joined:
    Dec 18, 2008
    Messages:
    3,447
    Location:
    Middle of the ocean.
    Country:
    United States
    All DSi XL are 1.4x
     
  5. qlum

    Member qlum Posting when needed

    Joined:
    Sep 25, 2008
    Messages:
    562
    Location:
    The Pirate Homeworld
    Country:
    Netherlands
    except the reversion 705 of the ezflash vi this card still needs a firmware update but all new cards are 805 so that won't be a problem
     
  6. hunnymonster

    Member hunnymonster GBAtemp Regular

    Joined:
    Mar 29, 2010
    Messages:
    184
    Country:
    United Kingdom
    Acekard 2i - does
    Supercard DSOne - doesn't
    Supercard DSOnei - with fireware (sic) 1.1 does, with fireware (sic) 1.0 doesn't
    Supercard DSTwo - does

    and so do others - as has been said, as long as they are updated to work with DSi v1.4 firmware.
     
  7. Bloodgod
    OP

    Member Bloodgod 嵐の王

    Joined:
    Mar 25, 2007
    Messages:
    806
    Country:
    United States
    ^thanks I was about to ask that question. Cause I have an old AceKard for an NDS I was planning to use.

    Does dealxtreme still sell those? if not ,where can I find a cheap place to get it?
     
  8. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    No they no longer sell flashcarts.

    Remember it's the Acekard 2i you need, not the Acekard 2.1.

    If you no longer have your NDS, you will have to buy an Acekard 2i which has been preupdated to 1.4 from places such as ShopTemp..

    If you can afford it though, you're probably better off with the DSTWO.
     

Share This Page