N3DS 2.1.0 Downgrade

Discussion in '3DS - Flashcards & Custom Firmwares' started by Hyoretsu, Dec 5, 2016.

  1. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Just noticed that Plailect's has been updated. Now, all devices go trough the OTP route. So does this means that downgrading N3DS SysNAND without having EmuNAND and CFW is now possible without bricking? If yes, gonna resume my getting otp.bin plan.
     
  2. Aletron9000

    Aletron9000 3DS Master

    Member
    1,602
    452
    May 10, 2016
    United States
    3DS ARM9 CPU
    it uses a ctrnand transfer to flash a 2.1 nand to your sysnand. it is safer and quicker than downgrading with emunand and then flash emunand. BUT, this does not mean you won't brick using it, there is always a chance of brick at any step.
     
  3. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,279
    Jan 28, 2016
    United States
    If you already have a9lh then you don't need your otp. It isn't used at all and isn't useful.

    The guide just added back what it was with the ctrtransfer method. You don't "downgrade" but instead flash a premade nand backup from a different console.
     
  4. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    I'm asking because some while ago, I got this reply to my thread about getting my otp.bin:
    Also, what exactly should I do if I already have a9lh+Luma3DS+BootCTR9+EmuNAND? Just uninstall a9lh, open homebrew on SysNAND (9.2), downgrade to 2.1 through CTRtransfer and re-install a9lh?
     
    Last edited by Hyoretsu, Dec 5, 2016
  5. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,103
    2,341
    Mar 8, 2012
    United States
    2.1 on N3DS is somewhat hackish; it involves re-encrypting the CTR-NAND partition using keyslot 0x04. (N3DS CTR-NAND is normally keyslot 0x05.) Some functionality probably doesn't work right, but it's usable for the purpose of obtaining the OTP.

    While Luma3DS does support 2.1 in SysNAND, A9LH uses an 8.x N3DS FIRM for the actual initial boot process, which AFAIK causes OTP to be disabled. You may need to do a CTRNAND transfer to 9.2, remove A9LH, then CTRNAND transfer to 2.1. (Remember to back up your sysNAND first.)

    (Sidenote: Do NOT, under any circumstances, close the screen while running 2.1 on an N3DS. This will result in a hard MCU brick that cannot be easily fixed.)
     
  6. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,279
    Jan 28, 2016
    United States
    @Hyoretsu You don't need to fetch your otp. It was only useful for the first time install. No homebrew programs use it expect for one but you can do the same thing with luma in ctrnand and better.
     
  7. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Yeah, I know, just want to make a backup of it.

    Also, just figured I lost my pre-a9lh backup, so gotta uninstall a9lh, make a backup while I'm on 9.2 SysNAND and then re-install a9lh anyways.
     
    Last edited by Hyoretsu, Dec 5, 2016
  8. Miles54321

    Miles54321 GBAtemp Advanced Fan

    Member
    846
    326
    Dec 16, 2010
    Gateway Headquarters with SonyUSA
    It can still brick I believe,

    Also, here's a tip, make sure you do not close a N3DS when in 2.1.0 it will brick!
     
  9. Quantumcat

    Quantumcat Dead and alive

    Member
    11,538
    6,201
    Nov 23, 2014
    Australia
    Canberra, Australia
    You don't need your OTP. Trying to get it is a huge risk with absolutely ZERO reward. Give it up!!!!
     
  10. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    I still gotta get my pre-a9lh backup because I lost it.
     
  11. Quantumcat

    Quantumcat Dead and alive

    Member
    11,538
    6,201
    Nov 23, 2014
    Australia
    Canberra, Australia
    No you don't - if you want to uninstall a9lh you can do so through SafeARM9Installer (and in fact you will have to to be able to downgrade to 2.1). If you want to be able to go back to an earlier version of your 3DS - getting a NAND backup right now without a9lh installed isn't going to help that.
     
  12. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Does a9lh blocks homebrew somehow? I'm trying to launch freakyhax, but when I select the QR code, nothing happens.
     
  13. Quantumcat

    Quantumcat Dead and alive

    Member
    11,538
    6,201
    Nov 23, 2014
    Australia
    Canberra, Australia
    Why do you need freakyhax on an a9lh console? Just use the homebrew launcher cia.
     
    KunoichiZ likes this.
  14. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Just don't put it in Sleep Mode? Turning off and rebooting is fine?
     
  15. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Done. Got my otp.bin and pre-a9lh backup. Right now, I'm restoring my 9.2 SysNAND backup. Only "hassle" I had was after I installed a9lh, because I still had BootCTR9's a9lh.bin, so it booted Luma3DS by default but stayed on black screen. At first, I didn't notice my splashscreen for Luma, so I tought I had bricked. Happily, I hadn't.

    Also, cool profile image.
     
    Last edited by Hyoretsu, Dec 6, 2016
  16. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    How did you go about uninstalling a9lh without a nand-backup from pre-a9lh?
     
  17. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    Latest SafeA9LHInstaller, press START.
     
  18. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    Flashing stock NFIRMs?
     
  19. Hyoretsu
    OP

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,579
    297
    Jan 17, 2016
    Brazil
    What's this? Only downgraded to 2.1, installed a9lh, restore previous 9.2 backup through Hourglass9 and restored my BootCTR9's arm9loaderhax.bin
     
  20. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    You mentioned wanting to take a clean NAND backup without a9lh installed, just not sure how you removed your currently installed a9lh if you even did.