My PSP has M33 3.71-4 - worth an update?

Discussion in 'PSP - Games & Content' started by CoconutCake, Jan 2, 2009.

  1. CoconutCake
    OP

    CoconutCake GBAtemp Regular

    Member
    162
    0
    Dec 16, 2008
    United States
    My PSP is still at M33 3.71-4. I haven't followed CFW much since then, and barely remember how to update it.

    Now I see M33 is all the way up to 5.02, and was thinking about playing my PSP again.

    Should I bother updating? Are there many games now that need higher than 3.71?

    If you think I should update it, what steps should I take? Can I go directly from 3.71 to the latest version, or do I need to load other versions first? Please tell what order to go in.

    Thanks for any help.
     
  2. Diablo1123

    Diablo1123 Newcomer

    Member
    1,432
    0
    Mar 9, 2008
    United States
    Underground
    Its only 5.00 M-33 If I remember corrctly, can't hurt to upgrade can it?
     
  3. SylvWolf

    SylvWolf Ave Dominus Nox

    Member
    707
    4
    Jul 30, 2007
    United States
    East Coast, USA
    I think the remake of the first Star Ocean remake needed 4.01 or higher, but I couldn't confirm this, as I just updated beforehand. I haven't heard of any other games, but I'm sure they exist. Also, for PSX games, there's more version of POPS to try out, inevitably leading to greater compatibility. Also, the PlayStation Store is available now, if you wanted to check it out on the PSP.

    P.S. The current version is 5.00 M33-4. Some other teams released some CFW's that had been upgraded further, but that's the latest one from D_A himself. Updating is really easy, search around a bit for the details. This site is great for getting the files: PSP Wiki
     
  4. myuusmeow

    myuusmeow GBAtemp Advanced Maniac

    Member
    1,643
    0
    Jun 24, 2007
    United States
    I know Hot Shots Golf Open Tee 2 needed at least 4.01M33 because it came with 3.96 on it.

    Anyway, you should be able to just go from 3.71M33 to 5.00M33 by downloading DA's and Sony's update files then running them.
     
  5. refugio

    refugio GBAtemp Regular

    Member
    108
    0
    Apr 26, 2007
    United States
    does anyone know what firmware dissidia requires? (sorry didn't want to make another topic)
     
  6. EarthBound

    EarthBound a/s/l?

    Member
    844
    3
    Aug 28, 2003
    United States
    Fort Worth,Texas
    I'm still using 3.71 M33-4, and it runs Dissidia/HSG:OT2 just fine.

    Edit: hmm Im at 3.90 M33-3..Dont remember doing that xfd
     
  7. grubbymitts

    grubbymitts GBAtemp Regular

    Member
    242
    1
    Sep 2, 2006
    5.0M33 is easy enough to install but it's advised to remove any prx hacks you may have installed as some people have complained of blue screening their PSP (basically semi bricking it) when installing it. But if you have no prx hacks installed then you should be fine. It is advisable to have a pandora battery available anyway just in case so you can always sort it out if you do cock up [​IMG]
     
  8. War

    War Take it easy~

    Member
    5,409
    8
    Oct 26, 2007
    California
    I'm using 4.01m33 and Dissidia works perfect
     
  9. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    I'm on 3.71 M33-4...i don't own Dissidia so have no idea if that one works but Star Ocean runs fine on 3.71 M33-4. Yggdra Union requires 4.01 though.
     
  10. SylvWolf

    SylvWolf Ave Dominus Nox

    Member
    707
    4
    Jul 30, 2007
    United States
    East Coast, USA
    Ah, I guess I was wrong about Star Ocean, then. Although I'm still glad I updated, as I've really gotten into Yggdra Union recently.
     
  11. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    You could always have played the virtually identical GBA version.
     
  12. claudekennilol

    claudekennilol GBAtemp Regular

    Member
    255
    5
    May 9, 2008
    United States
    I thought since 4.0 you could update it via the network updater? 4.01 to 5.whatever should be doable just by hitting the network update, yeah?
     
  13. monopoman

    monopoman GBAtemp Regular

    Member
    102
    0
    Aug 9, 2007
    United States
    Well actually you can now update using the official method and keep your CFW they hacked that so updating is no so easy its all automatic.

    Yeah it was like 4.00 M33 or something that started the easiest method known to man.
     
  14. cupajoe

    cupajoe Have a cup of joe!

    Member
    1,143
    0
    Aug 25, 2007
    United States
    Minnesota
    If I remember correctly, it can't hurt to not upgrade. I've been using 3.90 for months and only update if there is a reason I have to.
     
  15. Diablo1123

    Diablo1123 Newcomer

    Member
    1,432
    0
    Mar 9, 2008
    United States
    Underground
    Well you can always upgrade for the faster loading time thing, seems to work too.
     
  16. cupajoe

    cupajoe Have a cup of joe!

    Member
    1,143
    0
    Aug 25, 2007
    United States
    Minnesota
    I didn't even know about that. I'm a little embarrassed. I guess I never really checked out what the updates did.
     
  17. Diablo1123

    Diablo1123 Newcomer

    Member
    1,432
    0
    Mar 9, 2008
    United States
    Underground
    Well it was barely the newest update (5.00 M33-6).
    Which came out 5 days ago?
     
  18. xalphax

    xalphax Internet killed the Ponystar.

    Member
    1,270
    14
    Nov 18, 2006
    Croatia
    here'n'there
    if every game you want to play, every homebrew you want to use works... why upgrade?

    never run a changing system... no wait.... never change a running system!