Mplayer_CE + deinterlace filter?

Discussion in 'Wii - Emulation and Homebrew' started by jachall, Jan 17, 2010.

Jan 17, 2010
  1. jachall
    OP

    Newcomer jachall Newbie

    Joined:
    Jan 17, 2010
    Messages:
    4
    Country:
    United States
    Hello:

    I'm trying to get a deinterlace filter working with Mplayer_CE. I figured the easiest method is to add the necessary line(s) to mplayer.conf. However everything I've tried does nothing. From the documentation, I should be able to add "vf=pp=fd" which should enable ffmpegdeint (ffmpeg deinterlacer). I've also tried adding the line "vf=pp=al" to enable autoadjust for brightness. Still it does nothing. How do you use video filters with Mplayer_CE? Thank you very much!

    --
    Jachall
     
  2. jachall
    OP

    Newcomer jachall Newbie

    Joined:
    Jan 17, 2010
    Messages:
    4
    Country:
    United States
    I ended up getting the solution to this on another forum. The problem seemed to be that you need to use "vf-add" instead of "vf", so it should look like:

    vf-add=pp=fd

    This got the deinterlacer working as it should. It made the video a little choppy, but it's applying the filter.

    Thanks!
     
  3. Eddie_Brock

    Member Eddie_Brock GBAtemp Fan

    Joined:
    Apr 15, 2009
    Messages:
    341
    Location:
    Vancouver Island
    Country:
    Canada
    How choppy are we talking about? And what format/size was the file you played?
    I would be eager to enable deinterlacing for my standard .AVI movie (~700mb), but if its adding extra slowdown, its probably not worth it. Let me know please, I'm curious.
     

Share This Page