Moonshell 2.10 Full pack problem

Discussion in 'NDS - Emulation and Homebrew' started by koolkid1773, Feb 21, 2010.

Feb 21, 2010
  1. koolkid1773
    OP

    Newcomer koolkid1773 Member

    Joined:
    Jan 2, 2010
    Messages:
    34
    Country:
    United States
    Hiya. I just downloaded moonshell 2.10 full and when I booted it up, it came up with an error. I used the alternitive loader... SAME ERROR!!! [​IMG] [​IMG] I'm using an Acekard 2i with AKAIO software. PLEASE HELP!!!!!
    EDIT: I'm using a DS lite, and the error is: "A fatal error has occurred! The displayed filesize and the actual filesize are different. Recovery method:Backup all files to hard disk, and recopy after formatting card. Application terminated."
    EDIT: the error happened during the Disk Check.
     
  2. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    That isn't very informative. Did you dldi patch the nds file? What was the error? Was it just a black/white screen freeze? Was there the normal moonshell startup check that gave a logbuf.txt error?
     
  3. dnniwa485

    Member dnniwa485 GBAtemp Fan

    Joined:
    Oct 4, 2009
    Messages:
    458
    Country:
    my friend got a AK2i and he used alt. loader to boot it to Ak2i...

    and somehow.. it shows a error, and load stuck-up. And on that we DLDI the ROM and that, it boots correctly (somethings wrong with DLDI in AKAIO maybe) so manual patch it using the DLDI files provided on moonshell 2.10(located on misc folder)
     
  4. elmoreas

    Member elmoreas GBAtemp Regular

    Joined:
    Dec 20, 2009
    Messages:
    274
    Country:
    United States
    You shouldn't have too DLDI patch it. I know you said you had an error but try this. Put the memory card in the PC. Delete Moonshell altogether from it. Then redownload moonshell 2.10 (stable version) and unzip it. Then go into the folder it generates and click on setup and select the english and then the drive with the memory card in it and click install. This will install an new version of moonshell instead of updating it. Now put it in the card and the card in the DSi and run moonshell first with moonshell2 this should work and take you to a screen that has you select your language, again pick english, then go to the next screen where you select what to do with lines that are to long to display on one line, select display on 2 lines and do not show again then click okay, then you should be in moonshell. If the app gave an error when starting and didn't take you to the language selection screen right away then try the other the alt loader and direct boot and follow the instructions I gave on which ever one works. If they all 3 fail then I do not know what to tell you, you either have a bad card or some kind of software issue that is out of my league. I just did this for mine today and had no troubles, but make sure you are using 2.10 stable and not 2.10 as there is a difference and the stable version is likely been fixed for this issue and is what is behind your problem, if you are already using the stable version then maybe you got a bad download or perhaps part of your micro sd card is corrupted, or maybe there is a software conflict between moonshell and something else on the card (IDK that is getting out of my league), or perhaps your acekard has gone bad or the firmware is corrupt. I guess if all else fails and the prior version of moonshell worked for you, you could go back to it so at least you have that, until you can figure out what went wrong and how to fix it. I hope this helps a little. I wish you the best of luck. If you have any questions about what I did feel free to ask and I will do my best to answer you. Have a good one. Later.

    Sincerely,
    Elmoreas
     
  5. dnniwa485

    Member dnniwa485 GBAtemp Fan

    Joined:
    Oct 4, 2009
    Messages:
    458
    Country:
    i think you missed the readme file on the alternate loader.. its said that you need to DLDI patch it.. if im not mistaken. Or im just imagining.
     
  6. elmoreas

    Member elmoreas GBAtemp Regular

    Joined:
    Dec 20, 2009
    Messages:
    274
    Country:
    United States
    The alt loader needs patching yes but he was talking about using the regular loader first was he not, if not then I appologize, I misread your post. I thought the error was with the regular loader first and then with the alt loader second. The regular loader should not need patching the alt loader does. I am sorry for the confusion. My bad.

    Elmoreas
     
  7. dnniwa485

    Member dnniwa485 GBAtemp Fan

    Joined:
    Oct 4, 2009
    Messages:
    458
    Country:
    as well as you missed that you might need the alt loader for ak2/i users? cause of DLDI fatal error larger than 16gb disc?
     
  8. elmoreas

    Member elmoreas GBAtemp Regular

    Joined:
    Dec 20, 2009
    Messages:
    274
    Country:
    United States
    Koolkid1773 could you provide more information about the error and about your memory card, it would help in figuring out what is wrong and how to fix it. I am the first to admit that I am no guru when it comes to the Acekard, I am just trying to help, using my experiences from earlier today, but as I said I am no guru and there are other people more able to help you, with more information they will be better able to do so. Any further information you could post would be helpful. Thanks.

    Elmoreas
     
  9. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    xD The thread has come back to a full circle. If my understanding of google translate gibberish is correct, the alternate loader fixes up the problem with certain cards (AK2i, R4, DSTT) where the sound is nonexistent when certain things are done, and comes back when other certain things are done. The alternate loader does need to be patched though.
     
  10. elmoreas

    Member elmoreas GBAtemp Regular

    Joined:
    Dec 20, 2009
    Messages:
    274
    Country:
    United States
    Yes I said the alt loader needs to be pathced, when I said that it didn't need patching I was refering to the regular loader, I thought we had established that by now.
     

Share This Page