Majora's Mask and Gateway 3DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by Orcastraw, Mar 12, 2015.

  1. Orcastraw
    OP

    Orcastraw Advanced Member

    Newcomer
    68
    21
    Dec 24, 2013
    United States
    Houston, Texas
    Has anyone looked into this game as far as comparability with launching the Gateway hack? Any chance the exploit could be transferred over? OOT3D and MM3D are from the same developers, after all.
     
  2. reyyesrey

    reyyesrey Member

    Newcomer
    49
    16
    Mar 9, 2015
    United States
    New York, New York
    Seriously? No.
     
  3. Codename

    Codename GREEN BRO IS BEST BRO

    Member
    365
    85
    Feb 21, 2012
    Canada
    Sorry, but I don't think it would be possible because Nintendo pushed out a second revision of Ocarina of Time 3D cartridges awhile back that are patched the vulnerability that the Gateway exploit relies on. Based on that info, one can assume that they made sure the same vulnerability wasn't available in Majora's Mask 3D.
     
  4. motezazer

    motezazer GBAtemp Maniac

    Member
    1,214
    1,306
    Feb 6, 2015
    France
    Rev 1.1 didn't patch the vulnerability. Gateway team (or someone else) just need to port the saves.
    But I don't think this bug exist on MM3D.
     
  5. Codename

    Codename GREEN BRO IS BEST BRO

    Member
    365
    85
    Feb 21, 2012
    Canada
    Then what's exactly is preventing the exploit from running on Rev 1.1 copies of OoT3D?
     
  6. motezazer

    motezazer GBAtemp Maniac

    Member
    1,214
    1,306
    Feb 6, 2015
    France
    Mainly different offsets, I think.
     
    osaka35 likes this.
  7. Qtis

    Qtis Grey Knight Inquisitor

    Member
    3,797
    1,295
    Feb 28, 2010
    The Forge
    Wrong code execution. Having a single part wrong in a series of code can make it crash. If one version works and the second has the exploit still available, you'll be able to do it again if everything else is seen as constant. Just like the original 4.5 hack and CN exploit regarding up to 9.2 compatibility.
     
    osaka35 and Codename like this.
  8. Hashtastrophe

    Hashtastrophe Wizard

    Member
    439
    301
    Jan 12, 2015
    Canada
    Yes that kind of wizard.
    Same developer means nothing. Even slight changes between versions can break the exploit with the same game, a different game isn't going to work in 90% of cases. If it did it would still require a bunch of work to get it usable and might have bugs of its own that prevent it from being acceptable for general use.