M3 Lite Stopped Working

Discussion in 'M3 Adapter' started by personperson, Aug 22, 2011.

  1. personperson
    OP

    personperson Member

    Newcomer
    43
    0
    Jan 3, 2007
    Exactly as the title says, my M3 Lite stopped working. I have been using it constantly with my GBA SP with the proper adaptor cart and all of a sudden it stopped working. Sometimes its doesn't even start and others I can get to the menu but when i start loading a game the screen goes all screwy and it just doesn't load.
     
  2. Rayder

    Rayder Mostly lurking lately....

    Former Staff
    6,613
    133
    Jan 14, 2007
    United States
    USA
    I've been having this exact same issues with my M3 Perfect miniSD......it seems to be a connection issue. Whether it be with the GBA (or in my case, the DSlite) or it's SD card, I'm not sure. But it happens to me sometimes too. I just fiddle with the cart and SD (plug and unplug them a few times) and it goes back to working.

    Some people suggest that the battery may be dying, but if it still holds saves, so I don't think that's it.

    One time I fixed mine by copying everything from the SD, formatting the SD and then copying everything back. That might suggest a fragmentation issue.
     
  3. personperson
    OP

    personperson Member

    Newcomer
    43
    0
    Jan 3, 2007
    Hmm I forgot that, my saves also aren't working. I hope it isn't the battery, is there anyway to fix that?

    I'll try the formatting the sd thing though, thanks for the help.
     
  4. shaosam

    shaosam Advanced Member

    Newcomer
    59
    1
    Apr 30, 2007
    United States
    Clean out the electrical contracts on the M3 with a Q-tip and some rubbing alcohol. It could be as simple as the contacts being dirty.