Looking for testers for my guide.

Discussion in 'Wii - Hacking' started by koji2009, Mar 30, 2009.

Mar 30, 2009
  1. koji2009
    OP

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    (edit) Have enough testers for now. Waiting to hear back from everyone involved in the first wave and make sure none of them have any problems. If I need more testing, I'll ask again. If all goes well then I'll write the full guide that I can post here.


    I've just assembled a bunch of programs/files and created a quick and dirty guide for getting disc loading to work on 4.0 menu wiis using softmod. I'm looking for some guinea pigs willing to test it out.

    I'm not trying to pull a softmii... I have no intentions of taking any credit (my name won't even be on the guide) and I have no intentions to setup asking for donations... I just wanted to make a guide that'd be easy to follow for those ready to upgrade from 3.2-3.4 that had been using softmii or a similar guide previously.

    Do note, since there is no new version of preloader there isn't any real brick protection. I've tried the guide out on my NTSC 3.2 wii and fully upgraded to 4.0 with disc channel loading no problem, but I can't gurantee anyone's wii will be 100% safe. This guide should work for NTSC and PAL (there is only 1 step difference between the two, which is the start loader)


    If after reading all of this you're interested, send me a PM. If you're curious before hand what programs the guide uses...

    Wad Manager 1.3
    cIOScorps
    Startpatchv4.0
    cIOS36_R8 installer
    Wiigator's mios .2 installer

    (edit) forgot one thing! There is a prerequisite. You must be on a wii 3.2-3.4 with homebrew channel installed or menu 4.0 with a cIOS installed BEFORE updating to 4.0 as well as the HBC.

    If all works out well, I'll write a second guide that I can post publically here without all the wads in a few days that should be safe for everyone to use.]

    I once again take no credit for any of this and the true praise for everything belongs to the coders of the programs listed above. Thanks in advance, and again PM me if you're interested.
     


  2. lavamasta

    Member lavamasta GBAtemp Regular

    Joined:
    Feb 21, 2009
    Messages:
    197
    Country:
    United States
    i qualify for all the specifications... i dont see much point in it though... im gonna wait to upgrade. i wanna have my wii fully functional and be able to use the usb loader coming out soon! woot! cant wait [​IMG]
     
  3. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    Are you able to disc load at the moment on 4.0? What's the secret?
     
  4. koji2009
    OP

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    MrBubbles: I can disc channel load from 4.0 on my completely softmodded wii yes.

    The breakthrough was the release of startpatch just a few hours ago that removes the update check and the new cIOSCORP custom IOS60 which allows for the disc channel to recognise backups in 4.0
     
  5. mikeyt1998

    Member mikeyt1998 YouTube Glitcher

    Joined:
    Aug 11, 2007
    Messages:
    1,359
    Location:
    Dalton-in-furness, north west
    Country:
    United Kingdom
    hmm, i may indulge in this testing. never been part of a test before.

    if you want i'll get round to giving it a try.

    this is the exact reason i dont want to upgrade to 4.0E, no loading from disc channel lol

    however i am pretty scared about the result XD as in, i know a guy who's wii i softmii'd and it constantly said you need to update in the disc channel until i installed preloader and set skip updates...

    i just hope that doesnt happen to me lol

    hows about you PM me then i'll get back to you tomorow at about 6pm GMT coz i've got college lol

    i'm also a little bit sceptical about the space it'll take up on my wii, memory wise. i suppose that updating to 4.0 means the old cIOSCORP wads will be removed though lol
     
  6. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    I can disc channel load from 4.0 on my completely softmodded wii yes.

    I have CIOSCorp 2 installed and a MIOS for GameCube loading from disc channel.

    I'm willing to test this out.
     
  7. ajd4096

    Member ajd4096 GBAtemp Regular

    Joined:
    Feb 17, 2009
    Messages:
    175
    Country:
    Australia
    For maximum points you have to
    * put CONMFIRMED in the subject
    * claim it was leaked by your beta-testers.
    * say you "heard the disks spin the other way" [​IMG]

    Yeah, I'll give it a go.
     
  8. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    I'm currently updating. Guide seems very simple and YES you can still run GC backups with this. Will post results in a couple minutes.
     
  9. MizuhoChan

    Member MizuhoChan GBAtemp Regular

    Joined:
    May 29, 2008
    Messages:
    188
    Country:
    United Kingdom
    I'd just like to say, your guide is perfect. I followed everything to the letter and my Wii is now at 4.0 with everything working.

    You sir, require props.

    Incidentally, are the CIOS bugfixes required? You didn't mention to install them.
     
  10. koji2009
    OP

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    Sorry I didn't mention those specifically. Yes all of the cios in that folder should be installed. When I write the final guide I'll make it clearer.

    Also, I don't deserve any props. All I did was gather the programs and write a quick guide.


    If anyone has any problems at 4.0 you can always use anyregionchanger and be able to downgrade back to 3.2 without incident.
     
  11. MizuhoChan

    Member MizuhoChan GBAtemp Regular

    Joined:
    May 29, 2008
    Messages:
    188
    Country:
    United Kingdom
    Alrighty then, I'll go do those too.
     
  12. Joesalad21

    Newcomer Joesalad21 Advanced Member

    Joined:
    Oct 19, 2008
    Messages:
    53
    Country:
    United States
    You may not be able to help me, but im getting error -1017 when running StartPatch4.0 on my US wii.
     
  13. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    I finished everything.

    I can load GameCube backups but not Wii backups.

    Very strange indeed.
     
  14. koji2009
    OP

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    Joesa: Ah I just sent you my guide. Since you are having problems with startpatch on your current setup, I'd like to know what method did you use to upgrade to 4.0. Icefire's installer, Waninkoko's, or official.

    Also, would you mind downgrading and updating using the official nintendo server and trying my guide that way to see if you have any different result?

    Mr. Bubbles: Are you getting any sort of error? Or do they just not read or display in the disc channel?
     
  15. Joesalad21

    Newcomer Joesalad21 Advanced Member

    Joined:
    Oct 19, 2008
    Messages:
    53
    Country:
    United States
    I used Icefire's updater to update to 4.0

    and yeah I'll downgrade then update to official then use your guide.
     
  16. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    Well good news and bad news.

    Good news is I was wrong!

    Bad news is only games from my region work. I tried a Japanese Wii game first and it didn't know what to make of it. Then a NSTC-U game and it worked.

    I also installed region free channels and games, can anyone confirm if JP games don't work?

    Other than Japanese games I'm fine on my end.
     
  17. Littlegreenmen

    Member Littlegreenmen GBAtemp Fan

    Joined:
    Dec 16, 2008
    Messages:
    339
    Location:
    England
    Country:
    United Kingdom
    Test Report;-
    Starting system- 3.2e with Ciosrev8 & HBC installed.

    Followed your guide/package and now running sys 4.0e disc channel loading with updates blocked. PERFECT. Very easy to follow. If you could i would make seperate download packages for pal and ntsc so the incorrect starpatch cannot be accidently used. But overall this is in my opinion the best/safest method yet. Nice work dude.
    ps would be very nice if you could at screenshots in your manual- This could eventually be a alternative method to miiwii but for sysmenu4.0. ACE

    Game compatibility on PAL system;-
    No more heroes NTSC = OK
    PES2009 NTSC = Shows in disc channel but boots to black screen [please note this happened prior to my update] works ok through gamma channel
     
  18. koji2009
    OP

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    Hmm... I'm going to have to download and burn a couple out of region games to double check that everything is working right on my wii as well.

    As I said before if you have any issues or playing backups from another region is absolutely crucial from the disc channel (they should work perfectly fine from any loader, but if someone would double check for me just to be sure, I'd be most greatful) you can easily use anyregionchanger to downgrade back to 3.2 while I see if there is anything I can do about the issue on my side.

    Littlegreenmen: Thanks for the feedback if anything at all comes up (or more confirmation on the region issues) let me know and I'll see what I can do.
     
  19. MizuhoChan

    Member MizuhoChan GBAtemp Regular

    Joined:
    May 29, 2008
    Messages:
    188
    Country:
    United Kingdom
    In reponse to MrBubbles, I am a PAL user and I used a scrubbed Animal Crossing NTSC disc to test if it would boot, which it did.

    So perhaps it's due to your updating method, I used the official updater.
     
  20. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    I was on 3.2 then went to 4.0 officially. I tried Disaster and Fatal Frame, neither of them were read. So if you're a PAL user and other region games work for you, it might be an error on my end.

    I'll reinstall every WAD again and see what happens. Even if it doesn't work I can use the old Gamma loaders for the 3 region games that don't work.
     

Share This Page