Loadiine 4 - Super Mario 3D World loading problem

Discussion in 'Wii U - Hacking & Backup Loaders' started by pavachan, Nov 20, 2015.

  1. pavachan
    OP

    pavachan Member

    Newcomer
    12
    5
    May 28, 2010
    Iceland
    Hello all :)

    Today i have bought a Wii U Basic, updated it to 5.3.2, and followed all the steps in the guide here. My router would simply not block the stated urls for some reason, and even using TubeHax didnt work for some reason. It still returned a proper ip and dns on that nslookup site, when run from inside the wii u browser, let alone pc.

    What i then did was copy the entire 'Definitive Package' folder to my android, enabled a hotspot and disabled mobile data, and used the simple web server app to get things going. Figured i'd detail this in case it is relevant to the problem.

    My console is 5.3.2 E.
    I ran the moddified kernel exploit and went into Loadiine successfully.

    Now, i got 2 extracted USA game WUDs. Wind Waker and Super Mario 3D World.
    I set up the micro sd card (sandisk 64gb U1) as stated, and created the folder structure.

    SD:\wiiu\games\gamename\code and content
    SD:\wiiu\saves\gamename\c and u

    i copied over everything that was needed from the tutorial (prx file into code, and all of content into content).

    Wind Waker HD worked right away using Mii Maker mode, loaded super fast, everything works great.

    Super Mario 3D World, either with Mii Maker or with SSBU in the disk drive, seems like it's loading, with the white screen, and then i get an error, something along the lines of "Exception DSI occured", followed by what seems to be either some ram dump thing or cpu registers, the whole screen filled with it.

    Is there something i need to do i am not doing? change some filename or config file in SM3DW from USA to Eu? Could it be a bad WUD? Compat list says it works great in either mode :/

    Any advice would be appreciated. Thanks :)
     
  2. pavachan
    OP

    pavachan Member

    Newcomer
    12
    5
    May 28, 2010
    Iceland
    I found a solution by poking around a bit.

    In the folder "content\LuigiBros\msg" there was a folder called "USA_en". I made a copy of it, renamed it to "EUR_en".
    Also, in the folder "content\LocalizedData" there was a folder called "UsEn" which I also copied, and renamed to "EuEn".

    Super Mario 3D World now loads with Mii Maker mode, ~30 seconds load time, and works great!!

    Added it to the Compatibility List.
    Thanks all, and I suppose it is alright to close this?

    Bye for now :)
     
    Last edited by pavachan, Nov 20, 2015
    Faxic, WiiU and Taleweaver like this.
  3. Taleweaver

    Taleweaver Storywriter

    Member
    5,644
    1,660
    Dec 23, 2009
    Belgium
    Belgium
    Nice! I had this very same issue, and this fixed it. :)
     
  4. Xplic1T

    Xplic1T GBAtemp Regular

    Member
    197
    57
    May 26, 2006
    Had the same issue but in reverse ... had the EU folders but not the US ones :)
     
  5. EclipseSin

    EclipseSin FullMental Trollemist

    Member
    1,813
    1,287
    Apr 1, 2015
    United States
    Vegeta's Hyrule
    SM3DW was already on the list. Region issues and loadiine issues are not one and the same. Do not remove games from the Wiki marked as working if you're using an out of region copy of a game on your console please.
     
    emuman100 and gamesquest1 like this.
  6. bzImage

    bzImage Newbie

    Newcomer
    4
    2
    Nov 21, 2015
    Mexico
    Wrong.. thread sorry.
     
  7. pavachan
    OP

    pavachan Member

    Newcomer
    12
    5
    May 28, 2010
    Iceland
    I removed nothing from the Compatibility Wiki. I simply added a note explaining the folder renaming.
     
  8. dekuleon

    dekuleon GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    dekuleon is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    514
    160
    Oct 1, 2010
    Brazil
    where the wind makes the curve
    A little bit off topic: SM3DW is too slow to load... sadly.
     
  9. EclipseSin

    EclipseSin FullMental Trollemist

    Member
    1,813
    1,287
    Apr 1, 2015
    United States
    Vegeta's Hyrule
    No it's not. It takes less than a minute to load. It's your SD Card.
     
    Redirr likes this.
  10. dekuleon

    dekuleon GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    dekuleon is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    514
    160
    Oct 1, 2010
    Brazil
    where the wind makes the curve
    I'm using a genuine sandisk extreme, compared to my original disk, it is much slower.
     
  11. EclipseSin

    EclipseSin FullMental Trollemist

    Member
    1,813
    1,287
    Apr 1, 2015
    United States
    Vegeta's Hyrule
    So play your disc if you can't wait 28 seconds.
     
  12. mistak

    mistak Newbie

    Newcomer
    4
    1
    Dec 1, 2015
    Netherlands
    I changed the names of the maps to eu, but i'm stil getting the error message. maybe a bad wud??
     
    mahany_mahan likes this.
  13. mahany_mahan

    mahany_mahan Newbie

    Newcomer
    7
    0
    Apr 27, 2014
    United States
    i have same problem too.
    i renamed some EU folder in content folder to US but the problem dos not solved.
    can u help me ?
     
  14. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    124
    41
    Nov 24, 2015
    Netherlands
    ~ 30 seconds??!!?!?!? :wtf:

    * What SD card (brand, R/W speed/rating/class, etc.)?
    * How did you format the card (i.e. cluster size, FAT32 or exFAT), if at all?
    * Is your game updated? (according to WiiUBrew: USA title is at v1, and EUR at v0)


    I have this http://www.kingston.com/us/flash/sd_cards#sda3 (32 GB one) and it takes atleast 60 seconds before i'm able to press (A) in the game's title screen :wacko::angry:

    and:

    I also have this card: http://www.amazon.com/Lexar-High-Performance-MicroSDHC-Reader-LSDMI32GBBNL633R/dp/B00IF4OC8Y and it loads the game ~ 13 seconds faster than the Kingston one.
     
    Last edited by 2manyGames2play, Dec 2, 2015
  15. ComX

    ComX Member

    Newcomer
    23
    2
    Nov 2, 2015
    Gambia, The
    Have this Game: Super_Mario_3D_World_EUR_WiiU-ABSTRAKT
    and i only copy from data folder the Folders: code, content and meta to the SD Card folder: wiiu\games\Super_Mario_3D_World
    and it works fine with my 32GB SDHC from Sandisk. Using Loadiine 4.0 , and drom today 4.1
    Works very fast
     
  16. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    124
    41
    Nov 24, 2015
    Netherlands
    Well, i have the same release and copied the same folders.
    Do you know the exact model/type of your 32GB SDHC Sandisk card? The details u've mentioned is generic stuff =P
     
  17. ComX

    ComX Member

    Newcomer
    23
    2
    Nov 2, 2015
    Gambia, The
    Damn, Sorry, is Samsung EVO i have.. not Sandisk..
     
  18. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    124
    41
    Nov 24, 2015
    Netherlands
    And this is with Loadiine, not a Retail disc?

    So, in this case you're using a MicroSD + SD adapter?

    I still find it strange how fast your card is with this game. Most reports i've seen mention (much) longer load times.
     
    Last edited by 2manyGames2play, Dec 3, 2015
  19. 0nther0ck

    0nther0ck Member

    Newcomer
    29
    4
    Nov 18, 2015
    France
    Try to format in FAT32 64Ko. Load more fast for some game with lot of files ;)
     
  20. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    124
    41
    Nov 24, 2015
    Netherlands
    Thanks for the tip @0nther0ck . I'll let you know if it worked ;-)