1. skykid

    OP skykid Newbie
    Newcomer

    Joined:
    Mar 8, 2007
    Messages:
    7
    Country:
    United States
    I'm having a very confusing time with Retroarch currently. I connected an 8bit do pad at one point, and it worked fine with the first game I tried, but now all Joycons and bluetooth pads have gone very weird.

    When I play a game I've played with the Joycons before (connected to the Switch) it works fine - but when I boot any other game there's no response and I can't even hotkey to the retroarch menu. I need to quit the entire thing back to the main menu and start over.

    Additionally, I noticed that when I start a game where I get no input response, the controller configuration text on startup (the yellow text in the bottom left) will cycle through all the joypad numbers up to around six, and seem to jump randomly (as in #1, #4, #2, #5 etc).

    I have deleted the retroarch.cfg multiple times, and the retroarch config .cfg - nothing changes. I've made sure that the input in the .cfg isn't set to "null" and is set to "switch".

    Is there some way to actually figure out the problem here or do I need a complete reinstallation?

    Thank you for your help!
     
  2. TheCasualties

    TheCasualties Just trying to be helpful
    Member

    Joined:
    May 11, 2020
    Messages:
    439
    Country:
    Netherlands
    Dang, sorry this is happening. I'm not sure how to fix it but can offer some trouble shooting.. since no one else has come to help yet.

    1. try rebooting the system?
    2. System Settings > Controllers/Sensors > Disconnect Controllers
    3. delete and reinstall retroarch?

    Not sure if any of these will help but hopefully it gets sorted out. 1 is just standard troubleshooting. 2 might work if it's still confused because of the 8bitdo. 3 might help if some other file got messed up.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - recognition, Retroarch, (Switch)