Issue with Spirit Tracks

Discussion in 'NDS - ROM Hacking and Translations' started by Kav, Dec 19, 2009.

Dec 19, 2009

Issue with Spirit Tracks by Kav at 11:30 PM (1,765 Views / 0 Likes) 11 replies

  1. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    In my game, for some reason, I have an issue when trying to battle the ice temple boss. My game plays perfectly fine until I enter the room where the ice temple boss would normally be, where in the end both screens stay black (the same black screen that appears for 1 second when transitioning/loading to the next scene). I can't continue the game because of this issue, and I've tried using someone else's save file that was at the beginning of the ice temple and got the same result when I made it to the part before the ice temple boss. I'm thinking it would be a LOT easier for me if I could just find a .sav file that's right after the temple boss, and just continue from there...

    I've asked a friend of mine for his save file, and it works perfectly fine (it's at the sand temple; I'd rather not play it seeing as it's too far, but if I can't find a save file to use that's right after, or close to right after the ice temple I will have ultimately no choice on the matter).

    P.S. I'm thinking this issue might have happened after an issue with saving, where twice my game file saved and then froze right after finishing to save. I had copied the game file after the second incident to make sure I had a back up in case it happened again, where it did and my first file ended up corrupted. Thankfully I had the copy, and was able to play until the ice temple boss, where it ended up with this black screen problem.

    Thanks in advanced for the help, hopefully this is in the right place, and if not (or if these threads are not allowed), then please excuse me, I'm just a bit desperate because I'm travelling tomorrow and was hoping to be able to enjoy this game on the plane ride.
     
  2. wiifan420

    Member wiifan420 GBAtemp Regular

    Joined:
    Aug 21, 2007
    Messages:
    113
    Country:
    United States
    Here try this. http://www.mediafire.com/file/zg2lddndjdk/Zelda Spirit Tracks SAV.rar I think it may be just after I finished the ice temple (I backup alot [​IMG] ). Hope it helps. Save is originally for DSTT btw.

    Edit: ^^ Link looks weird but works fine
     
  3. Arp1

    Member Arp1 GBAtemp Regular

    Joined:
    Apr 15, 2009
    Messages:
    245
    Location:
    Minnesota
    Country:
    United States
    Is your rom patched? And what flashcart are you using?
     
  4. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    I'll try that out now wiifan [​IMG]

    And it's an r4, and I do believe it's patched.

    edit; The .sav file works, but it's about a temple too far [​IMG] (I'm guessing after the fire temple).

    But that's a lot better than at the sand temple at least! [​IMG]
     
  5. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    bump, if anyone has a .SAV right after the ice temple, I'd very much appreciate it [​IMG]!
     
  6. twiztidsinz

    Member twiztidsinz Taiju Yamada Fan

    Joined:
    Dec 23, 2008
    Messages:
    4,981
    Country:
    United States
    What kind of R4 do you have?
    Because you should probably be more interested in a fix for the problem so it doesn't happen again, rather than just using another save file.

    The problem could be that you have a clone with firmware that's not compatible with LoZ:ST.
    There are lots of clones, and if you bought it recently (within a year), you've most likely got a clone.
     
  7. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    Hm, I didn't buy the r4 recently, maybe a year or more ago (can't remember the exact date though).
    And how can I check what type I have? All I know is that it's black (sorry, I'm horrible at these kinds of things).
     
  8. twiztidsinz

    Member twiztidsinz Taiju Yamada Fan

    Joined:
    Dec 23, 2008
    Messages:
    4,981
    Country:
    United States
    A "No" to any/all of these would indicate you have a clone:
    -- Does it have a black philips (+) screw on the back?
    -- Does it have a circle depression with a plastic dot on the back?
    -- Is the MicroSD slot on the top of the card (opposite the contacts)?
    -- Does the MicroSD slot have an 'etch' of a MicroSD card below it?
    -- Is the 'etch' clean and crisp (not blurry/fuzzy)?
    -- Are the contacts "bright" gold (not dull or dingy)?
    -- Are the contacts uniform thickness with distinct, even gaps between them?
    -- Do the contacts end flatly and connect to the tracks/traces (not gradually taper off)?

    A "Yes" to any/all of these would indicate you have a clone:
    -- Does it support SDHC cards (MicroSDs over 2GB)?
    -- Is the case glued togeter or lacking a screw?
    -- Does the plastic feel soft or cheap?


    Can you open it and take a pic? (AT YOUR OWN RISK! If you don't feel comfortable or it is difficult to do STOP!!!!!)
    If you can't / don't feel comfortable opening it, can you take a good, clear pic of the contacts?
     
  9. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    Hah, yeah it seems I have a clone [​IMG]!
     
  10. twiztidsinz

    Member twiztidsinz Taiju Yamada Fan

    Joined:
    Dec 23, 2008
    Messages:
    4,981
    Country:
    United States
    Now it's just a matter of finding out which clone you have.
    Some R4 clones can use YSMenu (DSTT firmware with a different interface), which runs Spirit Tracks perfectly fine.
     
  11. Kav
    OP

    Newcomer Kav Newbie

    Joined:
    Dec 19, 2009
    Messages:
    6
    Country:
    Canada
    Ok, let me pull as much info as I can.

    I would take a photo, but have no access to a camera (we're travelling in about a half hour, so I'm semi-rushed at the moment).

    Anyways, it's black, I'm pretty sure it's the same design as the white one.
    It has a sideways H sign (It doesn't really look like an I, because the top and bottom lines are pretty long) at the back (which I accidentally tried to scratch off in the past so sometimes if I'm not careful, my game will freeze, which is probably what happened in what I said in the Opening post)
    2 GB micro SD at the top in it's slot.

    On the front it says:
    R4
    Revolution for DS
    (NDSL/NDS)

    When I turn it on this is the generic info I'm given (unincluding brackets):
    (top)
    R4
    Revolution for DS
    R4DS English version

    (bottom)
    R4 Revolution for DS
    two smiley faces for games | two music notes for multimedia | bootslot (don't really know what the image is, seems like a square smiley face in two shades of blue)

    v1.18 Game Date Time
     
  12. markvn

    Member markvn GBAtemp Regular

    Joined:
    Mar 14, 2009
    Messages:
    205
    Country:
    Netherlands
    Well, that's the Mac logo. Look....
     

Share This Page