is there a new 3ds update?

Discussion in '3DS - Console, Accessories and Hardware' started by TheGreek Boy, May 26, 2016.

  1. TheGreek Boy
    OP

    TheGreek Boy GBAtemp Advanced Fan

    Member
    802
    250
    Jan 9, 2016
    Greece
    Behind you.
    i have 11.0.0-33 emunand and when i'm trying to access the E-Shop tells me to update to update the system :wtf:
     
  2. Justinde75

    Justinde75 VGM Addict

    Member
    1,679
    2,104
    Feb 14, 2016
    Germany
    Iwatodai Dorm
    Please use the Search function there was a similiar Thread yesterday
     
    Xiphiidae and pbanj like this.
  3. keepitoriginal

    keepitoriginal Member

    Newcomer
    46
    7
    Apr 27, 2016
    United States
    You should try to see if you can update Luma, go to the hourly update and do that. i was having the same issue and also with online play and did that and it worked. guess it was a bug that caused that from what i was told.
     
  4. Deletr753

    Deletr753 GBAtemp Regular

    Member
    110
    17
    Oct 14, 2013
    Guatemala
    If you are running a CFW some of your files may be outdated or did not update correctly. That happen to me before.
     
  5. TheGreek Boy
    OP

    TheGreek Boy GBAtemp Advanced Fan

    Member
    802
    250
    Jan 9, 2016
    Greece
    Behind you.
    same with GW mode
     
  6. nero99

    nero99 GBAtemp Addict

    Member
    2,021
    936
    Sep 18, 2014
    United States
    You have to use the latest nightly build of luma3ds or reinand.
     
  7. TheGreek Boy
    OP

    TheGreek Boy GBAtemp Advanced Fan

    Member
    802
    250
    Jan 9, 2016
    Greece
    Behind you.
    i'm using the latest
     
  8. Chenru

    Chenru Member

    Newcomer
    10
    0
    May 29, 2016
    United States
    Unites States, Ohio
    This is most likely due to the new 3DS program added in the 11.0.0 33-U update known as ASLR. It disables EmuNand users from accessing the eshop or any other internet related application. What is ASLR? Address space layout randomization (ASLR) is a memory-protection process for operating systems (OSes) that guards against buffer-overflow attacks by randomizing the location where system executables are loaded into memory. Therefore, disabling lower firmware users from accessing eShop.
     
  9. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,110
    2,353
    Mar 8, 2012
    United States
    ASLR has nothing to do with being able to access the eShop. That limitation is provided by eShop checking CVer/NVer.

    EmuNANDs running 11.0 have no issues accessing eShop.
     
  10. CheatFreak47

    CheatFreak47 Complex Donut

    Member
    1,397
    1,014
    Oct 11, 2011
    United States
    Michigan, USA
    I always love it when people copypaste information they found by googling to make it seem like they know what they're talking about, when in fact they don't.

    Continuing off of what @GerbilSoft was saying, the ASLR they added was actually for preventing OOT3DHax and Ninjhax from working, which was poorly implemented, EmuNAND and other hax users are fine, you just need to be running the latest Luma 3DS for it to work, Luma3DS 5.5 released yesterday with fixes for that and a few other issues, and before that you could've been running the nightlies, which had fixes for that.

    Helpful Links:

    Luma 3DS Releases Page

    Star Updater Releases Page
     
  11. Chenru

    Chenru Member

    Newcomer
    10
    0
    May 29, 2016
    United States
    Unites States, Ohio
    I was just trying to post a helpful reply so that he could get a better understanding, Not at any time did I say I was trying to "talk like I knew what I was doing" Thank you. I hope this cleared some mis-understanding.
     
  12. Favna

    Favna #PCMasterRace

    Member
    810
    394
    Sep 12, 2009
    Netherlands
    1: verify you have Luma 5.5
    2: Verify you're not using dev build/mode
    3: verify you're using arm9loaderhax
    4: verify you're only using updated sysnand mode
     
    Jayro likes this.