1. ButThouMust

    OP ButThouMust Newbie
    Newcomer

    Joined:
    Jan 16, 2021
    Messages:
    2
    Country:
    United States
    I imported an NTSC-J copy of Kirby's Return to Dream Land (Hoshi no Kirby Wii, SUKJ01) for about $20 to play on my NTSC-U Wii. With both GeckoOS and USB Loader GX, I can only get as far as pressing 2 on the title screen before the game freezes on a white screen. After some research, I found out that this is due to the Metafortress anti-piracy/anti-tampering routine in the game, and I found patches (gameconfig.txt files, see below link) to disable it in the NTSC-U and PAL versions. However, I could not find such a patch for the NTSC-J version; does one exist?

    I tried forcing each patch on the NTSC-J disc in GeckoOS and USB Loader; for example, I copied in the PAL patch but changed SUKP01 to SUKJ01. However, the game would not even boot with either patch. Disabling hooktype lets me get up to pressing 2 on the title screen.

    gbatemp.net/threads/kirbys-return-to-dream-land-white-screen.462119/page-2#post-8528664
    Game Language: Japanese
    Force NTSC/PAL60/PAL50: No
    Gecko Hook Type: VBI
    Load debugger: No
    SD File Patcher: No
    SD Cheats: No
    Gecko Pause Start: Yes (the game would not boot if I set this to "No")
    Bubbles On: No

    Game lock: off
    Favorite level: 0
    Video mode: System Default
    Dol Video Patch: off
    Sneek Video Patch: off
    VIDTV Patch: off
    Aspect ratio: System Default
    Game Language: Japanese
    Ocarina: off
    Private Server: off
    Parental control: 0 (Everyone)
    Hooktype: VBI (Default)
    Wiird debugger: off
    Game IOS: Use global (249; d2x-v10beta52, base 56, rev 65535)
    Return to: off
    Block IOS reload: on
    Nand emulation: Use global (full)
    Nand emu path: Use global (not set)
    Alternate DOL: off
    Select DOL offset: Not required

    sysCheck v2.1.0b19 by Double_A and R2-D2199 Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)

    Drive date: 2007.02.13
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 75873752
    Boot2 v4
    Found 140 titles.
    Found 50 IOS on this console. 14 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS236[58] (rev 21 Info: rev 21): Trucha Bug
    IOS247[37] (rev 21007 Info: d2x-v7final): Trucha Bug
    IOS248[57] (rev 21007 Info: d2x-v7final): Trucha Bug
    IOS249[57] (rev 65535 Info: d2x-v10beta52): Trucha Bug
    IOS250[56] (rev 65535 Info: d2x-v10beta52): Trucha Bug
    IOS251[58] (rev 65535 Info: d2x-v10beta52): Trucha Bug
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10

    Report generated on 2021/01/16.
    Slots 236, 247, 248 are from when my brother had originally hacked our Wii years ago. I followed the cIOS guide at wii.guide/cios.
     
  2. ButThouMust

    OP ButThouMust Newbie
    Newcomer

    Joined:
    Jan 16, 2021
    Messages:
    2
    Country:
    United States
    I solved my issue. I had downloaded Dolphin a week ago to try running it with a rip of my disc, but I didn't find out until today that Dolphin contained my solution the whole time.

    In /Dolphin-x64/Sys/GameSettings, there's a file SUKJ01.ini that contains the NTSC-J Metafortress patch. I just had to reformat the .ini file's contents to make it compatible with USB Loader GX/GeckoOS (e.g. change "0x80175194:dword:0x48000084" to "poke(80175194, 0x48000084)"). And voila, now I can play the game on my Wii.

    I guess I'll attach the NTSC-J patch here for the maybe single-digit number of people who need it...? I couldn't find it with just a Google search a week ago.

    Edit: "with just a Google search" in the last sentence instead of "anywhere on the Internet"
     

    Attached Files:

    Last edited by ButThouMust, Jan 24, 2021
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Metafortress, Kirbys, Return