Is it safe to update a soft modded Wii?

Discussion in 'Wii - Hacking' started by MrDoopliss, Feb 4, 2017.

  1. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    My wii was hacked back in 2009. The ver is 3.4. I would like to start over, and i would like to know. Is there any way i can update my wii to 4.3U? Thanks in advance.
     
  2. John_Ice

    John_Ice GBAtemp Regular

    Member
    198
    29
    Sep 14, 2009
    United States
    Here we go! Mama mia!
    No problems, just update your wii online to 4.3 and redo the softmod with Modmii for menu 4.3...
     
  3. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    Before doing the update, i have to delete all my Homebrew stuff right?
    (Homebrew Channel, USB Loader GX and Video Player)
     
  4. JPnintendo

    JPnintendo GBAtemp Regular

    Member
    153
    10
    Dec 3, 2009
    Argentina
    No, in fact, the update will try to delete weird things on the system.
     
  5. petethepug

    petethepug PUG

    Member
    1,366
    360
    May 2, 2016
    United States
    COMPUTER
    If nothing is installed to the system (Like a modded IOS) then your mostly good. But if you installed something to your NAND, or IOS you should take caution updating.
    If there's an option to uninstall apps (completely) I would recommend doing so,

    The last thing you would want to happen is your Wii deleting one of the main functions on it thinking its a mod.
    But then again I never have had to update my Wii when it was modded :P. So just ignore me
     
  6. tbb043

    tbb043 Member

    Member
    1,044
    461
    Jan 30, 2008
    United States
    Is there really an reason to go to official before updating a hacked Wii? I seem to recall it's perfectly fine, even preferred, to just use ModMii.
     
  7. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    Shit.
    So.. i updated. However, it gave me error 32007. The wii settings does say i have 4.3U and i can access the SD Menu. However, i can't access Wii Shop or do the letterbomb hack.
    Any way i can fix error 32007?
     
  8. petethepug

    petethepug PUG

    Member
    1,366
    360
    May 2, 2016
    United States
    COMPUTER
    You could try this if you can still access Priiloader,


    But instead of doing the actual update in the end go into Letterbomb to see if you can install Homebrew.
    If your still getting the issue you could try ModMii.

    Actually scratch that. I think it would be better off using ModMii since you already exploited it before. But again I don't actually know if its exactly completely safe to reinstall it through letterbomb since you previously installed it with another exploit on 3.4 FW.
     
    Last edited by petethepug, Feb 6, 2017
  9. sks316

    sks316 GBAtemp's Mewtwo

    Member
    1,615
    866
    Nov 28, 2013
    United States
    Alola
    I needed to get here earlier.
    I would have said to remove the modded content and then update, but...
    Then this. I don't know about error 32007 as I wait for a console to become "obsolete" and then I update to the latest firmware and mod it. Try to Google a tutorial because IDK.
     
    petethepug likes this.
  10. petethepug

    petethepug PUG

    Member
    1,366
    360
    May 2, 2016
    United States
    COMPUTER
    Well its better than just guessing for the most part.
    https://en-americas-support.nintendo.com/app/social/questions/detail/qid/45379/~/fix-update-32007
    Its a network issue, or the Wii itself with Homebrew.

    If you seen my previous answers you would see why its better to say "I don't know" instead of "Yes this how you fix it". :P
     
  11. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    No worries, it was just a network issue.
    Currently i have 4.3U, Homebrew Channel and right now i'm downloading some apps from the Homebrew Browser.
    Thanks to everyone for the advices anyway!
     
  12. sks316

    sks316 GBAtemp's Mewtwo

    Member
    1,615
    866
    Nov 28, 2013
    United States
    Alola
    Yeah... If I remember correctly, the Homebrew Browser's apps are INCREDIBLY outdated. Download apps from wiibrew.org instead.
     
  13. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    Yeah, i did. Now i only have to install USB Loader GX and i'm done.
    USB Loader GX didn't need a SD card to work. How do i do this?
     
  14. petethepug

    petethepug PUG

    Member
    1,366
    360
    May 2, 2016
    United States
    COMPUTER
    If you still have USB Loader GX installed, you could try just entering the channel from
    the home menu (Basically the forwarder.) (If you don't have it you have to install the WAD using MMM Manager, or something similar.) (If you don't remember uninstalling it, or want to check if its still installed.)

    The WAD also required some files on the SD Card & HDD in order to be boot into.
    If the WAD by chance does not work you will need to reinstall it normally.

    There should be plenty of guides & tutorials as well.
    Heres the official page of USB Loader GX
    Edit: Forgot to add it.
    https://gbatemp.net/threads/usb-loader-gx.149922/
     
    Last edited by petethepug, Feb 7, 2017
  15. azzarod

    azzarod Member

    Newcomer
    45
    10
    Jan 3, 2017
    I wouldn't use the channel you had back in 2009 - the old channel was a full version of USB Loader, not just a forwarder (meaning you'll be loading an outdated version, and will probably have trouble trying to load newer games).

    I'd delete the current channel (if you had one), and use the latest versions in the link provided by the previous poster.

    Good luck!
     
  16. petethepug

    petethepug PUG

    Member
    1,366
    360
    May 2, 2016
    United States
    COMPUTER
    Ah I forgot. You couldn't just install USBLoader like a regular WAD, it required multiple files in order to opeate and custom IOS's. I kinda forgot how it was installed >_<

    It was a nightmare to get it to run on my Wii (Well atleast for me.)
     
  17. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    Hmm alright. I already installed some stuff, so all i have to do is install USB Loader. I'll check the post. Thanks.
     
  18. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    Ok, i really need help right now. I don't want to follow old tutorials so i'm going to ask here.
    I'm trying to install USB Loader GX FULL CHANNEL (Not the forwarder).
    But when i try to install it, i get error 1029.
    I tried switching to IOS 222 and 250 and i get error 1022
    I only have the .wad file in the SD on the wads folder (USBLoader_GX_V3_0_UNLR_Channel_AHBPROT.wad)
    What can i do to install it? Do i need a different CIOS? If it's something CIOS related, please explain it in full detail.
    And don't tell me to install CFG USB Loader. I don't like it.
     
  19. MrDoopliss
    OP

    MrDoopliss Member

    Newcomer
    28
    2
    Feb 4, 2017
    Cote d'Ivoire
    In the meantime, i installed USB Loader GX on the Homebrew Channel and it works perfectly! All my ganes are still there and there are no issues.
    The reason i would like to have the full channel is because i don't always have my SD Card.
     
  20. azzarod

    azzarod Member

    Newcomer
    45
    10
    Jan 3, 2017
    Unfortunately the full channel is no longer supported - if you find one, it will be an old version and will probably cause you problems with many of your newer games.
    For the latest version of USB Loader GX, it's either Homebrew menu or a forwarder - both of which need the SD card. If having an SD card is an issue, you might wan to try eBay - it's pretty cheap to get a small one that you can permanently leave in the Wii.