is it my flashcart dying, or the microsd?

Discussion in 'NDS - Flashcarts and Accessories' started by concealed identi, Sep 30, 2011.

  1. concealed identi
    OP

    Member concealed identi GBAtemp Fan

    Joined:
    May 16, 2008
    Messages:
    341
    Country:
    Japan
    Hey everybody, I was hoping I could ask for some advice from people who might know what's going on.

    I have a CycloDS with 2.3 firmware and a Toshiba microSD that I've had for a few years. Every once in a while, the DS wouldn't recognize the flashcart, but I could just take it out, put it back in, and it would be fine. Not sure how relevant that is, but I thought I would say it anyway.

    Anyway, recently I've been having all sorts of weird problems come up a bit more frequently. Along with the above problem, these also happen:


    1. I put the microSD in the card reader and used it in my PC, ejected it safely, etc., but when I put it back in my Cyclo and turned the DS on, it said the SD card was not formatted correctly. If I put it back into the PC, it would say the same thing, and so I would have to reformat the card and put everything on again from a backup. The fact that this happened twice is kinda weird to me.

    2. Games tend to be freezing a bit now, usually either when coming out of sleep mode or when loading / changing screens.

    3. Sometimes the Cyclo goes into a black-screen recovery mode (which I've never seen before), telling me it can't find an update and asking if I want to load from the microSD (which gives me an error if I say yes).

    4. At times it says it can't find the microSD card.


    I've tried cleaning the contacts on the card, DS, and microSD, but it didn't seem to do anything. The problems occur enough that I can't really feel comfortable playing a game, since I've lost tons of saves already, but they don't occur reliably enough that I can troubleshoot (e.g. my computer detects the microSD, but so does the Cyclo most of the time, so I can't just say that's the problem).


    So has anybody had similar problems? Anybody know what's going on? I figure I'm gonna have to pony up for either a new flashcart or microSD (or both), but if I know which one is causing the problems, I'd prefer to just have to buy one of them.


    Any help is greatly appreciated! Thanks in advance!
     
  2. concealed identi
    OP

    Member concealed identi GBAtemp Fan

    Joined:
    May 16, 2008
    Messages:
    341
    Country:
    Japan
    although I'm still interested in what may have happened, I just ordered an AceCard DSi and 4gb microSD for $25...this whole thing has gotten way cheaper in the past few years! kind of a problem, considering I just got these for less than I just paid for Kirby Mass Attack...
     
  3. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    sounds like either your microsd is going or the reader is bad. keep in mind that msd cards have a limited number of read/writes. it could be as simple as that you need to reformat it with the panasonic formatter, give that a try.

    -another world
     
  4. concealed identi
    OP

    Member concealed identi GBAtemp Fan

    Joined:
    May 16, 2008
    Messages:
    341
    Country:
    Japan
    thanks for the advice, but I don't think that would matter...when I was forced to reformat, that's the software that I used. Don't think it's the reader either, as that wouldn't explain all of the other problems.

    Don't think it has anything to do with read/writes, as I have microSD cards with way more use on them, and I think the limit is somewhere around 100,000 or something huge like that...


    Ah well, they're both cheap enough to replace, so I'll hope for the best!
     
  5. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    not all micro sd cards are built the same, and even the same card is not built the same. i've had cards fail under normal use and cards which are still working after beta testing thousands of files.

    when a msd card starts to go it will often corrupt quicker which can cause all of the problems you are experiencing. when a reader goes it can corrupt the card when it is ejected. i've had both of these things happen. is your reader getting hot by any chance (especially after moving around lots of files or a full format)?

    when a msd card is going the panasonic formatter may say it was formatted correctly but the card will not perform as expected. i've also had this happen. you may want to try some usb specific tools to scan the card. you could have corrupt sectors or a bad partition.

    i would suggest a new reader and a reformat before you spend any money. if that fails then replacing the msd card is the next affordable debugging step.

    its less likely that the issue is with the cyclods micro sd slot, although not out of the realm of possibility. i’ve spoken, at length, with a few developers who had the cyclods microsd slot destroy their microsd card. it appears to be less of a common issue but after discussing it with them (and running tests) its evident that it was the flash kit itself which caused the problems.

    -another world
     

Share This Page