Iphone 4 update questions

Discussion in 'iPhone, iPod & iPad' started by Nismax, Mar 31, 2014.

  1. Nismax
    OP

    Nismax GBAtemp Regular

    Member
    185
    60
    Sep 13, 2009
    United States
    I got a hand me down Verizon phone that is sitting on ios 4.2.8 which I believe is stock, I don't think it's ever been updated.

    Is it in any possible way to update to an ios version other than 7.1 or whatever the most recent version is? Either via jailbreaking or otherwise forcing an unsigned ispw install?

    From what I've read, it is supposedly impossible if there are not "blobs" from a previous install of the version I want to use. I have attempted a 6.3.1 install via itunes which returned the ineligible error. I then used Tinyumbrella and ran the server, itunes then did proceed past the point where the error pops up, but there was no progress with the install after that. Just sat there at "preparing".

    I want some apps that require a higher version, but also do not want to gimp the phone in the process. Do apps on Cydia have the same ios version requirements as is the case in the App store? If not, I suppose I will just jailbreak it.
     
  2. juins

    juins GBAtemp Fan

    Member
    495
    68
    Sep 13, 2003
    MAYBE it has been jailbroken in the past. Download Tinyumbrella and check to see if cydia has downloaded blobs
    If u dont have any blobs, then im afraid 7.1 is your only option. Btw, download ifaith and save your currently installed 4.2.8 blobs with ifaith so u can downgrade to that version whenever u want.

    I dont recall if 4.2.8 is untethered, 7.1 is only tethered at the moment.
     
  3. Nismax
    OP

    Nismax GBAtemp Regular

    Member
    185
    60
    Sep 13, 2009
    United States
    Thanks, I didn't know I could downgrade from 7.1 (even with blobs). I will make sure to back them up before updating or jailbreaking. Just did a quick search and it seems anything lower than 4.3.3 is untethered. So I will probably just jailbreak it first just to see if I can get desired apps on such an old iOS.

    BTW: It was my Mom's phone, no way it's been jailbroken, she never even updated it:P
     
  4. juins

    juins GBAtemp Fan

    Member
    495
    68
    Sep 13, 2003
    Never hurts to check if u got blobs with tinyumbrella.

    4.2.8 was a release specifically for cdma phones i believe, i never got the chance to use it, i was one 4.2.1 (untethered) then updated to 4.3.3 (untethered).

    But yea, if u feel like updating , make sure u grab your 4.2.8 blobs that are installed on your current flash. Only ifaith can do this.

    I personally would stay on 4.2.8 too and untether it. Ios 7 is a bit slow on iphone 4 unless your jailbroken and install something like springtomize.

    Either decision, update or stay on 4.2.8, grab your blobs in cass something bad happens and u have to restore.

    But wait, about a year ago, apple implemented legacy downloads for ppl on older ios versions, if u try to download something with your apple id on the appstore..

    Dont u get a popup with something similar asked to u when u try to DL something?
     
  5. Nismax
    OP

    Nismax GBAtemp Regular

    Member
    185
    60
    Sep 13, 2009
    United States
    I actually did check for the blobs while attempting to update to 6.3 via TU server deal. Nothing showed up, not even 4.2.8.

    But I did go ahead and back up the 4.2 blob with ifaith as suggested. I then went ahead with the jailbreak, but that was rather pointless. So I went ahead and updated to 7.1, got my Google Voice apps. Lets see, $50-$100 a month for a cell plan, or free voice and text over wi-fi on a free iphone. Tough choice...