internal mic mutes itself

Discussion in 'Computer Hardware, Devices and Accessories' started by Bubsy Bobcat, Feb 13, 2016.

  1. Bubsy Bobcat
    OP

    Bubsy Bobcat halloween peener

    Member
    1,472
    5,703
    Jul 8, 2015
    Zimbabwe
    Hey, I'm having this problem with one of my laptops (Toshiba Satellite C50-B-14D) and it's really bugging me. I want to be able to use my built-in mic for Skype conversations and what-not which works perfectly fine without any headphones plugged in, but whenever I have anything plugged into the only audio socket, my internal mic mutes itself which is really annoying since I want to have headphones in whilst talking instead of everything coming out of the speaker. I've been messing about with settings and searching online but I can't seem to get my mic to work with headphones plugged in. Any ideas? :(
     
  2. LittleFlame

    LittleFlame Thinks he's better than all of you

    Member
    755
    2,146
    Jan 30, 2015
    Netherlands
    That one place
    Do you have anything set to a "Communication device"?

    — Posts automatically merged - Please don't double post! —

    like so? [​IMG]
     
  3. Costello

    Costello Headmaster

    Administrator
    12,411
    5,700
    Oct 24, 2002
    did you look here:

    upload_2016-2-13_21-42-16.png

    and here:

    upload_2016-2-13_21-41-54.png


    and here:

    upload_2016-2-13_21-42-38.png

    ?


    also here:

    upload_2016-2-13_21-43-6.png


    and here:

    upload_2016-2-13_21-43-26.png
     
  4. Bubsy Bobcat
    OP

    Bubsy Bobcat halloween peener

    Member
    1,472
    5,703
    Jul 8, 2015
    Zimbabwe
    Yep, it just shows my built in microphone (Realtek High Definiton Audio) which picks up sound that I make when nothing is plugged into the audio socket. As soon as I have something plugged in, it acts like I've muted it.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,110
    5,179
    Mar 17, 2010
    Norway
    Alola
    That laptop seems to have a 4-pin headphone/mic combo jack, like the ones you find on every modern phone. So when you plug in headphones, it switches to the microphone input on the combo jack, which doesn't work since you're using regular headphones.

    Do you have more than one input listed in Recording Devices or in your Realtek HD Audio Manager? If so you can disable the jack input, but if you only have one mic input then the single input is likely shared between the 3.5mm jack and the internal mic and there's nothing you can do unless there's an option to disable it buried somewhere in a manufacturer-specific control panel.

    Edit: Honestly I find built in mics on laptops to be of poor quality and have a lot of noise, so they're not very well suited for skyping. If you have a headset with a separate mic and headphone jack you can get an adapter to plug both into the combo jack and you will get much better mic quality that way, and you will also solve your problem.
     
    Last edited by The Real Jdbye, Feb 13, 2016
  6. LittleFlame

    LittleFlame Thinks he's better than all of you

    Member
    755
    2,146
    Jan 30, 2015
    Netherlands
    That one place
    Turn off the communication device just disable what you don't want to use
     
  7. Bubsy Bobcat
    OP

    Bubsy Bobcat halloween peener

    Member
    1,472
    5,703
    Jul 8, 2015
    Zimbabwe
    Never mind, I got it to work by opening up Realtek HD Audio Manager, going to my microphone, going to Device advanced settings and selecting Seperate all input jacks as independent input devices. All is well now! ^_^
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,110
    5,179
    Mar 17, 2010
    Norway
    Alola
    Oh yes, forgot about that option :)
     
    Bubsy Bobcat likes this.