Hacking Interesting Issue. I've done some extensive troubleshooting...

demosthenes2010

New Member
OP
Newbie
Joined
Dec 22, 2020
Messages
1
Trophies
0
Age
36
XP
15
Country
United States
Hello All,

I am an IT consultant and like to think of myself as being pretty technically savvy generally. I have built out 13,000 game emulation machine with dozens of systems.
I am aware that this is not emulation and that this is not IT consulting. I mention these things only to help people not waste their time with very basic troubleshooting steps.
I am generally aware of how the various pieces of this process should work yet I can't figure out why this particular issue is occurring for me.

So, I had originally set up my Wii to use USB Loader GX and everything was working fine.

I had loaded my original 70 games or so using WBFS Manager 4.0. These were originally ISOs that WBFS Manager 4.0 converted into WBFS and placed on the new external HD which WBFS Manager 4.0 had just formatted for me.

All 70 games worked correctly through USB Loader GX.

I later found about a dozen games that I also wanted to load.

This time I used Wii Backup Manager because I'd downloaded them in WBFS format and realized that WBFS Manager 4.0 would not allow me to place them on the drive.

Here is where it gets interesting.

Both WBFS Manager 4.0 and Wii Backup Manager can see the games.

USB Loader GX will only show those games added to the drive by Wii Backup Manager.

USB Loader does list the storage space of the external HD and not the SD card at the bottom, so I know that it recognizes the external HD and appears to know that it is the primary storage device.

I am able to pull all 82 games from the drive back to my PC (which I am doing now) and I'm assuming that after formatting the drive and copying them all back that they will all show up (all 82 of them) but I'm curious what Wii Backup Manager might be doing that would confuse USB Loader GX.

Some hints -

At first, I thought that perhaps it had something to do with the MD5 Hash. Wii Backup Manager did not have any MD5 hash listed for the games loaded by WBFS Manager 4.0 so I attempted to generate them using Wii Backup Manager. Perhaps this had something to do with it?

The only way I have to see what is on this WBFS formatted drive is through these tools (Windows/Explorer cannot read the drive) so all I really have are these list views in each application showing me different levels of details but both confirming that the games are at least present on the drive.
So, both applications can see the other's games.
USB Loader GX could, at one point, see the games from both.
All on the same WBFS partition.
All formatted correctly (they've all loaded at one point or another).
It seems that Wii Backup Manager did *something* to the 70 games that were loaded by WBFS Manager 4.0 but I am not familiar enough with the nuances of USB Loader GX to know what.

Several hours later...

Copied over all of the WBFS formatted games from the Wii external HD. (Remember, all of them worked at one point in time or another).

Reformatted the HD as a WBFS drive.

Copied them all back over using Wii Backup Manager.

Somehow, only the 12 games that I originally transferred over with Wii Backup Manager still appear within USB Loader GX... even though the other 70 were all working yesterday AND Wii Backup Manager transfers them without issue.

Quadruple checked all of the settings in USB Loader GX that I know to check.

Still no luck.

So, on to the next step of troubleshooting.

I know that WBFS Manager 4.0 doesn't copy WBFS formatted backups to a HD (not sure why) so I am using Wii Backup Manager to convert all of the WBFS files (all 82 of them) back into ISO's.

Then, I will allow WBFS Manager 4.0 to format the drive again.

Then, I will use WBFS Manager 4.0 to convert the ISOs into WBFS formatted files again and move them onto the Wii HD.

I figure, the first time I got the external HD to work with USB Loader GX, it was with a drive that was formatted by WBFS Manager 4.0 AND the games were converted and moved over using WBFS Manager 4.0. Perhaps if I let WBFS Manager 4.0 handle the ENTIRE thing, USB Loader GX will recognize all of the games...

Several hours later...


I found a solution...

Even after reformatting the drive and using WBFS Manager 4.0 to copy ALL the games over, USB Loader GX still only shows the twelve games that were originally placed on the external HD by Wii Backup Manager.

On a hunch, I removed the SD Card and selected the option at the bottom of USB Loader GX to "Reload SD".

All of the games appeared properly.

Something about loading the second batch of games from Wii Backup Manager convinced USB Loader GX to only see all of the games IF the SD card is removed.
Not sure what is going on here...
I know that it isn't reading the 12 games from the SD card itself because... well, one, I didn't place them there...

But also because I have taken the card out of the Wii, plugged it into my PC, and see that it is almost completely empty.

Anyway, that is the "solution" for now. If anyone has any idea what configuration within USB Loader GX is causing this, I'd very much appreciate an explanation so I can fix it on my side.

All I can figure is, Wii Backup Manager changed some sort of configuration file or directory or metadata in some of the second batch of WBSF files and when USB Loader GX saw that, it defaulted to checking the SD card for the game backups. Weird thing is, the SD card doesn't have any of those backups on it so perhaps there is some sort of shortcut thing occurring? I don't know.... very weird...

Another update -
Before, when I had the first 70 games loaded, I was able to press "1" on the controller and use the built in functionality of USB Loader GX to download covers and images.

Now, it gives me the following errors -
Error! Can't create directory usb8:/config/images/
Can't create directory usb8:/config/images/2D/
Can't create directory usb8:/config/images/full
Can't create directory usb8:/config/images/disc
Can't create directory usb8:/apps/usbloader_gx/cache_bnr/
No file missing!

Which drive is identified as usb8 on the OS level?

Is the Wii having difficulty accessing a device or directory due to some sort of privileges issue?

I wonder if this is related...

I attempted to use the "Default Settings" option within the Settings to remove anything that may have been wrongly configured. No change...

Sorry for writing a book about this. I just know that it helps me whenever I'm trying to help others if they are especially detailed in their reporting. Am hoping an expert sees this and has all they need to point me in the right direction. :-)
 
Last edited by demosthenes2010,
General chit-chat
Help Users
    kenenthk @ kenenthk: Would've been fine if they didn't reverse the connection leads