InstallIOS38 - Will download and patch IOS38

Discussion in 'Wii - Hacking' started by WB3000, Nov 18, 2008.

  1. WB3000
    OP

    WB3000 GBAtemp Advanced Fan

    Member
    668
    1
    Apr 5, 2007
    United States
    I've taken the IOS51 and Shop Channel installer by tona, and changed the source to download the latest IOS38. This IOS is being distributed with Animal Crossing, and possibly is needed for Wii Speak features to function properly.

    I am almost positive that this will work, and have uploaded the source code here. The only thing I can think of, is that Nintendo might not have IOS38 on their servers yet (unlikely).

    I have left the patching option included, so it will prompt whether to include the signing patch or not. I am assuming that PatchMii covers the whole patching process, as there is only a boolean to specify patch or not. This is the main reason I created this, as I want a safer IOS38 installed.

    If anyone could compile this, and possibly test, it would be greatly appreciated. [​IMG]
     
  2. idunnoilikends

    idunnoilikends GBAtemp Fan

    Member
    393
    0
    Jun 8, 2007
    United States
    doesnt ios38 block homebrew?
     
  3. DarkLG

    DarkLG Wow One Shiny Ribbon!!!!

    Member
    1,401
    5
    Jun 21, 2007
    United States
    Indiana
    Ya does it or does it just enable wii speak use?
     
  4. WB3000
    OP

    WB3000 GBAtemp Advanced Fan

    Member
    668
    1
    Apr 5, 2007
    United States
    Most likely it is for Wii Speak, just being in the background won't harm homebrew.
     
  5. noobwarrior7

    noobwarrior7 GBAtemp Advanced Maniac

    Member
    1,594
    1
    Aug 2, 2008
    United States
    USA
    umm....well it doesn't block anything, but it doesn't have the signing bug in itself.

    all we know for sure is it's what animal crossing runs off of.

    its harmless.
     
  6. chaoshawk

    chaoshawk Advanced Member

    Newcomer
    54
    0
    Oct 19, 2008
    Canada
    So being harmless, we could just update it through the game no?
     
  7. Reser

    Reser GBAtemp Regular

    Member
    104
    0
    Jun 8, 2007
    Everyone is saying it enables Wii speak, however I do not have IOS38 and I have had someone talk to me with a MIC in my game, so if it does indeed enable wii speak then it is only the 'talking' side and drivers or whatecer to enable the mic it and not the reciving side.

    So you do not need it if you just want to hear other people.
     
  8. noobwarrior7

    noobwarrior7 GBAtemp Advanced Maniac

    Member
    1,594
    1
    Aug 2, 2008
    United States
    USA
    well no, cause there are other IOS on the disc, 3.3 IOS (not the newest 3.3, but still...any 3.3 sucks)

    this is the only one it needs for standard boot.
     
  9. LegendaryXM90

    LegendaryXM90 GBAtemp Regular

    Member
    216
    0
    Sep 29, 2008
    United States
    With what game?
     
  10. Diffusion

    Diffusion GBAtemp Advanced Fan

    Member
    701
    1
    Jul 14, 2007
    United States
    Animal Crossing: City Folk has the June 16th version of 3.3...

    So you're fine with updating from the disc on 3.3U.
     
  11. LegendaryXM90

    LegendaryXM90 GBAtemp Regular

    Member
    216
    0
    Sep 29, 2008
    United States
    NOBODY ELSE ASK IF IT IS SAFE TO UPDATE FROM THE DISC.

    *points an arrow at noobs getting ready to type out the question*
     
  12. WB3000
    OP

    WB3000 GBAtemp Advanced Fan

    Member
    668
    1
    Apr 5, 2007
    United States
    I want to keep my system at 3.2, as it's the best System Menu for homebrew compatibility, trucha, etc. Sure 3.3 is "safe", but it's not that great either.
     
  13. Diffusion

    Diffusion GBAtemp Advanced Fan

    Member
    701
    1
    Jul 14, 2007
    United States
    Pretty sure, IOS38 isn't on Nintendo's server.
     
  14. Hideous

    Hideous GBAtemp Regular

    Member
    112
    0
    Apr 9, 2007
    It doesn't enable WiiSpeak, since it uses the same microphone drivers as Boogie and Rock Band, and such.
     
  15. WB3000
    OP

    WB3000 GBAtemp Advanced Fan

    Member
    668
    1
    Apr 5, 2007
    United States
    Now that 3.4 is out, we'll need more than just a patched IOS38, probably a 50 too.
     
  16. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,709
    362
    May 3, 2006
    France
    You can maybe extract IOS38 from the AC CF disk with Trucha and then install it with WADManager.
    You can try Waninkoko' IOS Downgrader to patch it.

    Don't know if it work...
     
  17. whitegoose

    whitegoose Member

    Newcomer
    33
    0
    Nov 11, 2008
    Canada
    i was going to try re-dumping my animal crossing game to my PC via wiihttp dumper as i have already patched and deleted the ISO from my PC. so, if i re-dump the game, i will try and check what you need from it.... problem is i've never done this before.

    i learn fast, but im still a noob to all of this. i just got into following the homebrew scene like 3 weeks ago and i feel like im trying to play catch up.

    i'll re-dump the ISO and check it over with wiiscrubber, but after that i'll probably be lost. i think i can use wii scrubber to extract the IOS 38 from the disc, correct?
     
  18. requiem4d

    requiem4d GBAtemp Regular

    Member
    181
    0
    Oct 25, 2008
    United States
    50 is up at http://www.softchip-mod.com/. Also includes patch for new Mii Channel.
    38 is NOT yet on nintendo's servers.
    [​IMG]
     
  19. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,709
    362
    May 3, 2006
    France
    Yeah, that works with Wiiscrubber too.
     
  20. whitegoose

    whitegoose Member

    Newcomer
    33
    0
    Nov 11, 2008
    Canada
    alright, i'll get working on that later today then. maybe i can try and talk my girlfriend through how to use wiihttp dumper over the phone so its ready for me when i get home [​IMG]