Installing GBA Cia VC game

Discussion in '3DS - Homebrew Development and Emulators' started by Chrisssj2, Aug 28, 2015.

  1. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    hi guys I tried to install Golden sun cia file gba game VC... but when I start it all I get is a black screen?

    Did I do something wrong?
     


  2. Megaben99

    Megaben99 I'm not an intern. I'm a messenger of the Gods!

    Member
    285
    97
    Mar 19, 2015
    United States
    Are you installing it to SysNand and EmuNand both?
     
  3. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    I think only emunand. How do I install to sysnand using Devmenu. (cant use fbi because I can't seem to get to install it on my new3ds)
     
  4. Megaben99

    Megaben99 I'm not an intern. I'm a messenger of the Gods!

    Member
    285
    97
    Mar 19, 2015
    United States
    Not sure bro .. I used FBI to install the GBA game on both the SysNand and EmuNand and use rxTools CFW. With it installed on both it will play on EmuNand.
     
  5. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    I also don't wanna install custom firmware to be honest.. Last time I did that messed up my new3ds too...
    Hopes someone knows a way..
     
  6. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    You should select destination NAND with FBI when installing this. Devmenu automatically picks destination depending on what kind of cia it is, so you don't need to care about that. If you're gonna install something to sysnand, boot into sysnand and then install it.
     
  7. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    Like I said I can't seem to use FBI for some reason. No other way?
    ALso I can't run devmenu via sysnand can I? I am using gateway

    Also I read this @ fbi topic:

    Q: Can I install any CIA I want via Ninjhax? / I'm getting an "Invalid signature" error!
    A: No. Without something that patches signature checks, such as emuNAND or a CFW, you cannot install CIAs that are not properly signed.

    that means u cant install on sysnand anyway?
     
  8. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    "via Ninjhax". emunand is just an emulation of sysnand that you can use to play on the lastest firmware and stuff. Devmenu is an application that can be used to install cia files.
     
  9. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    Yeah but u cant run devmenu for me unless I put my gateway.. which starts emunand llol
     
  10. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Of course you're not able to run devmenu without booting gateway sysnand. Since i understand you have no idea how to do that i'll tell how.
    When you're launching the Launcher.dat, hold L button until you get to the menu so it won't boot directly into emuNAND. Press and hold B and then press A and it will ask you if you want to boot gateway sysnand. Press X to do so.
     
    Chrisssj2 likes this.
  11. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    LOL you can run gateway in sysnand..?

    I read this in instruction from a certain website:
    To use them, install the patched AGB_FIRM with devmenu_2x.cia (and not BigBlueMenu

    How do I know if I am using devmenu 2x or bigbluemenu? Does this really matter? (the prog is called devmenu on my gateway)

    And finally is It really safe to install N3DS AGB_FIRM Patched.cia via devmenu? just want to double check since it's sysnand..
     
  12. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Well you've always been able to run gateway in sysnand.
    Yes it's safe to install the patched agb firm, but first i need to know, do you have an Old 3DS or New 3DS? (Old 3DS is the regular and New 3DS is the one released this year)
     
  13. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    I got a new3ds 9.0 firmware.
    Maybe I should install devmenu_2x.cia that is given in starting post, via my current devmenu to be sure I am using right devmenu? do you think this is adviseable?
     
  14. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    The devmenu_2x.cia work best. Also after you've installed the cias, you can't play the gba games in gateway. You'll need to use something like PastaCFW.
     
  15. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    Oh..
    I will try, I don't need to the firmlaunch instructions do I for gba vc?

    WHen I have installed pasta CFW I can acces it via Nintendo ds profile? and not need cubic ninja again?
     
  16. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    You'll need Cubic Ninja for it. (Would've been a lot easier if someone ported rxtools to the N3DS..)
     
  17. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    I have cubic ninja :) needed it for gateway to run on n3ds anyway
    installing it now
     
  18. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Ok. You can remove gba cia files from emunand since you won't be able to use them there. If there's anything wrong, ask me.
     
    Chrisssj2 likes this.
  19. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,327
    114
    Feb 12, 2008
    Netherlands
    I have run pasta cfw from ninja hax.
    but it returned me to the Operating system. and went to settings... said version 9.0.0 . not Pasta CFW 9.0 or anything..?
     
  20. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Use NINJHAX 1.0 since 2.0 is ONLY homebrew and for 9.3+