Information about plailects dsiware downgrade

Discussion in '3DS - Homebrew Development and Emulators' started by HolyHobo, Nov 7, 2016.

  1. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    I found this on plailects guide and I'm wondering how this is even possible, and does anybody have any information on how soon "soon" is?

    https://plailect.github.io/Guide/nfirm-downgrade

    "If you are on 11.0.0 or 11.1.0, do NOT update to 11.2.0. A new update will be coming soon that allows for DSiWare NFIRM Downgrading without a second 3DS or hardmod for versions under 11.2.0."

    This would/will be legendary
     
  2. dragon_from_iso

    dragon_from_iso GBAtemp Regular

    Member
    121
    64
    Dec 24, 2011
    read it wrong
     
  3. eworm

    eworm GBAtemp Regular

    Member
    157
    80
    Jul 7, 2016
    Poland
    A new exploit is coming that will allow 11.0 and 11.1 (but NOT 11.2) users to downgrade (and thus get CFW) via DSi downgrade. This will require a legit copy of a compatible game, the best option being Fieldrunners - available via eShop, but might be taken down in time due to, well, this.

    As to when exactly this happens, we don't know. The most common prediction is December, I believe.
     
  4. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    how would we be able to inject the dsiware hack into the game without a second homebrewed 3ds though?
     
  5. eworm

    eworm GBAtemp Regular

    Member
    157
    80
    Jul 7, 2016
    Poland
  6. Cralex

    Cralex GBAtemp Regular

    Member
    112
    43
    Jul 29, 2016
    United States
    A new exploit, one that'll work on 11.0 and 11.1, but not 11.2.
     
  7. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    That's amazing, since yellow8 released that dsiwarehax installer isn't a 11.1 downgrade possible right now? Or is it still in the alpha stage and iffy?
     
  8. eworm

    eworm GBAtemp Regular

    Member
    157
    80
    Jul 7, 2016
    Poland
    It still needs an actual kernel exploit, that's what we're waiting for. Yellows8's installer just injects the hacked save into the game (if I understand correctly), but for now we can't do anything with it.
    Patience. I have a 11.0 2DS, also waiting with baited breath, but it's gonna happen sooner or later.
     
  9. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    Ah makes sense, but if there's kernel exploit discovered on 11.1 what would be the point of downgrading?
     
  10. eworm

    eworm GBAtemp Regular

    Member
    157
    80
    Jul 7, 2016
    Poland
    We're waiting for Arm11 exploit, which will allow to downgrade and "unlock" Arm9 exploits used for A9LH and more.
     
  11. Arkansaw

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    no need to wait if you already have an exploitable set
     
  12. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    Ah ok, That's what I was thinking, so basically we're waiting for a possible arm11kexploit from plailect, that will be awesome!
     
    Last edited by HolyHobo, Nov 7, 2016
  13. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,714
    2,120
    Jan 11, 2016
    Japan
    日本
    Not from plailect..
     
  14. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,151
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    The arm11 Kernel exploit PAIRED with yellows's8 dsiware save installer will allow you to downgrade NATIVE_FIRM down to 10.4 and proceed with the normal dsiware downgrade via the plaintext attack. other than that, not much else.

    That still doesn't give you a new arm9 kernel exploit (and this guy would be the one to render downgrades unnecessary)

    The installer, right now, won't do anything on non-hacked/arm11userland only consoles.

    The only need for a 2nd already hacked console on 11.0 and beyond is because you can't install the save on your own after 11.0. and the saves transfer between system transfers.

    This would be dangerous to even try on a9lh consoles (what for, anyway?) as that will overwrite firm0/1 writing garbage to it and not only eliminating a9lh but bricking as well. only recoverable with hardmod. CFW+a9lh protects you from arm11 bricks, but not arm9 ones. (since this is where a9lh even runs from)
     
  15. HolyHobo
    OP

    HolyHobo That guy you see around but don't know

    Member
    179
    63
    Oct 2, 2016
    United States
    US
    Cool, thank you all for your replies :)