Hardware I think my battery is busted

derteufel

Well-Known Member
Member
Joined
Mar 28, 2015
Messages
124
Trophies
0
XP
206
Country
United States
So I think my battery got screwed up after not using my Switch for over a month. It wasn't hooked on to a charger or anything so it ran out of power and remained that way until I grabbed it again last night.

At first it wasn't charging at all, even after leaving it overnight. Did that trick where you hold down the power button for 15 seconds and tried charging it while it remained off this way. A minute or two later I wanted to see if it would turn on at all so I tried that. It had enough juice to where I was able to turn it on and access both OFW and CFW. However, it would not charge at all while powered on. Tried charging both on OFW and CFW and it wouldn't charge either way. Stayed at 1% even after it was plugged in for over an hour.

I went ahead and tried that 15 second trick again to power it off entirely. Left it off for a little over two hours. When I came back to it the battery was at 100% However, it started rapidly losing its charge as soon as I took it off the charger. Within less than 30 seconds it went down from 100% to 70% battery life without any games or applications running. If I keep it plugged in it doesn't lose charge, but it also doesn't charge.

It sounds like a hardware issue to me. Planning on replacing the battery myself (hopefully it's as easy as YouTube makes it seem) However, I'm wondering if there is anything I should keep in mind as a CFW user. Doubt a battery change would interfere with CFW at all, but I figured it's best to be safe than sorry.
 
Last edited by derteufel,

derteufel

Well-Known Member
Member
Joined
Mar 28, 2015
Messages
124
Trophies
0
XP
206
Country
United States
it's not in auttorcm?

No.
It's charging now. But the battery will go down from 100% to 0% in under 5 minutes without any games running. I've ordered a new battery online so I'm hoping this fixes the problem I'm having. Fingers crossed.
 
Joined
Mar 17, 2010
Messages
21,097
Trophies
0
Location
Alola
XP
11,915
Country
Norway
So I think my battery got screwed up after not using my Switch for over a month. It wasn't hooked on to a charger or anything so it ran out of power and remained that way until I grabbed it again last night.

At first it wasn't charging at all, even after leaving it overnight. Did that trick where you hold down the power button for 15 seconds and tried charging it while it remained off this way. A minute or two later I wanted to see if it would turn on at all so I tried that. It had enough juice to where I was able to turn it on and access both OFW and CFW. However, it would not charge at all while powered on. Tried charging both on OFW and CFW and it wouldn't charge either way. Stayed at 1% even after it was plugged in for over an hour.

I went ahead and tried that 15 second trick again to power it off entirely. Left it off for a little over two hours. When I came back to it the battery was at 100% However, it started rapidly losing its charge as soon as I took it off the charger. Within less than 30 seconds it went down from 100% to 70% battery life without any games or applications running. If I keep it plugged in it doesn't lose charge, but it also doesn't charge.

It sounds like a hardware issue to me. Planning on replacing the battery myself (hopefully it's as easy as YouTube makes it seem) However, I'm wondering if there is anything I should keep in mind as a CFW user. Doubt a battery change would interfere with CFW at all, but I figured it's best to be safe than sorry.
When you drain the battery to 0% until it shuts off and boot into Hekate what does the battery %/voltage there say?
 

Site & Scene News

General chit-chat
Help Users
    kenenthk @ kenenthk: Never knew these were a thing...