1. Negronicus

    OP Negronicus Member
    Newcomer

    Joined:
    Feb 15, 2017
    Messages:
    24
    Country:
    United States
    hello, i recently found my cyclods evolution cart, which i would always use on my ds phat. Its on firmware 2.2, my question is which ds consoles is this compatible with? Cause id prefer to use it on something with a bigger screen than my old ds. Also, what are the benefits to upgrading firmware and how would i do so?
     
  2. Lilith Valentine

    Lilith Valentine GBATemp's Official Cubi: *pout* :f
    Member

    Joined:
    Sep 13, 2009
    Messages:
    23,759
    Country:
    Antarctica
    Every single DS below the DSi will work just fine with that cart.
     
  3. Technicmaster0

    Technicmaster0 GBAtemp Psycho!
    Member

    Joined:
    Oct 22, 2011
    Messages:
    4,245
    Country:
    Gambia, The
    The latest firmware is 2.3. It should have a slightly better game support and maybe a few bug fixes and a few small feature updates. Updating the firmware (althoug the term firmware isn't used correctly by the cyclods team) should be completely save. It should be enough to download the latest firmware and extract the new file over the old one (it should be called boot.ievo or something if my mind serves me correctly).
     
  4. deltax5

    deltax5 GBAtemp Regular
    Member

    Joined:
    Dec 28, 2006
    Messages:
    143
    Country:
    So it will work on the dsi right? It just doesn't do the enhance features of the dsi right, thats what the i evolution is for right?
     
  5. Mark McDonut

    Mark McDonut GBATemp's Resident Ghostbuster
    Member

    Joined:
    Oct 8, 2008
    Messages:
    829
    Country:
    United States
    No, all versions of DSi console blocked out the original CycloDS due to hardware revision and legit retail cart whitelisting (and the cyclods not being on the list of allowed) in the console firmware. A DS phat and a DS lite will work ok since they have their firmware on a rom chip that doesn't upgrade, but anything beyond that you need the CycloDSi unfortunately, regardless of the need for DSi support, it's just an added feature to allow homebrew to access the faster Clock speed, Camera, SD Card etc.

    And if I recall the DSi retail support was kind of limited since a lot of scene dumps were done kind of hacky and didn't handle retail DSi support correctly (since they were being dumped to play on DS-based cards) but that may have changed recently with 3ds-based cart dumpers.
     
  6. Technicmaster0

    Technicmaster0 GBAtemp Psycho!
    Member

    Joined:
    Oct 22, 2011
    Messages:
    4,245
    Country:
    Gambia, The
    There are many DSi enhanced game dumps rolling out, thanks to pussycat. But it's still not many games.
     
  7. Mark McDonut

    Mark McDonut GBATemp's Resident Ghostbuster
    Member

    Joined:
    Oct 8, 2008
    Messages:
    829
    Country:
    United States
    Yeah it's kind of a bummer. would be nice if there was a way to convert the dsishop nds files to play them off a cart, but since 3ds supports repacked dsi files on NAND I'm not sure if any vendors or coders would be interested in such a project.
     
  8. Technicmaster0

    Technicmaster0 GBAtemp Psycho!
    Member

    Joined:
    Oct 22, 2011
    Messages:
    4,245
    Country:
    Gambia, The
    There will probably a DSi eShop ROM loader soon with the teasered exploit and SRLoader.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - CycloEvolution, recently, (help)