I need help with USB Loader GX...

Discussion in 'Wii - Backup Loaders' started by HeroicGamer, Jul 22, 2017.

  1. HeroicGamer
    OP

    HeroicGamer Newbie

    Newcomer
    9
    0
    Mar 3, 2017
    Hey everyone! So, just today I bought a 64 GB USB drive to store all my Wii and GameCube backups on. I have both Nintendont and USB Loader GX installed correctly and updated to the latest version. However, the USB drive can only be formatted to NTFS format or exFAT format. I saw somewhere online that USB Loader GX can use NTFS format, so I stuck my games on there like that. I have my wbfs folder and all my Wii games in .wbfs format inside of that folder. As for Nintendont, I have USB:/games/whatever.iso (which worked perfectly fine on its own drive). On another, much smaller USB, I had it in WBFS format and a few games on there as well.

    So basically, I have this:
    Nintendont:
    Can't read NTFS drives maybe? Can't open my 64 GB drive. Games properly placed on drive, though.
    USB Loader GX:
    Boots up, gets to "Initializing HDD Drive..." and then crashes. If I boot without a USB inserted and then place it when it starts counting down, it also crashes. This all happens on my 64 GB drive.

    My 4 GB drive = formatted FAT32.
    Nintendont:
    Boots up games fine. USB:/games/whatever.iso seems to work perfectly.
    USB Loader GX:
    Formatted to WBFS, boots up most games no problem. Except for Kirby's Return to Dreamland, so I have to use NeoGamma for that one. Other than that, works beautifully.

    So... what's going on? Is 64 GB too big? I've seen people go bigger, so that can't be it. Is it because it is NTFS? Is there a program that allows me to force-format it to FAT32? Windows says my only options are "NTFS" and "exFAT (Default)", although it said something similar with a 32 GB microSD card I had. I downloaded a program called SD Formatter or something and it fixed it no problem, perhaps there is a similar program for USBs? Or maybe that program will work with USBs anyway? I don't know, but I would really appreciate your help on this.

    Thank you,
    ~HG

    P.S. My main goal is to be able to play GameCube games and Wii games from the same 64 GB drive. The 32 GB microSD card is unavailable.



    EDIT: Good news! I found a program that lets me force-format NTFS to FAT32, and it worked. Nintendont is working smoothly once more. Also, USB Loader GX stopped crashing! Hooray! ...but now, it's showing all of my Wii Menu channels... I found an option to turn that off and to boot from HDD, but when I do that, no games appear and the pointer becomes really laggy. Also, you can press any button and it'll make the sound and everything, but nothing will happen. Not even the Home button on the Wiimote works. It basically crashes from a different spot. Should I delete my current .wbfs files/folders and try to move them again? The program that force-formatted kept all the files while it converted, so maybe that's why. I don't know, but I'll keep experimenting...
     
    Last edited by HeroicGamer, Jul 22, 2017
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,667
    8,254
    Oct 27, 2002
    France
    Engine room, learning
    Windows doesn't allow format of devices bigger that 32GB (which is dumb because FAT32 can be formatted up to 16TB partitions), it's a prehistoric issue and they never lift the limitation.
    you need a program to format drives in FAT32 instead of the default Windows's partition format option.


    About your new issue now:
    when you launched the loader and it couldn't find the HDD, it automatically disabled USB and switched to "channel mode".
    You said you found how to switch the USB back on. (4th icon).

    Maybe it still think your HDD is in NTFS or even previous WBFS (it has some kind of cache).
    Try this :
    settings > HDD settings > click on the first option to force a HDD partition refresh, and be sure it find "FAT32 64GB"

    reinstalling the .wbfs files shouldn't be needed, if the files are at the correct location with correct name it won't change anything to copy them again.

    another thing you can try :
    - delete the full config file (or reset the settings from settings menu)
    - set IOS58 as default IOS in the loader's settings > loader's IOS. it fixes a lot of user's HDD detection issues.
    - if your drive is a flash drive (most likely), it can have issues. you should use hard drives instead. flash drives are known to cause issues.
     
    Last edited by Cyan, Jul 22, 2017
  3. HeroicGamer
    OP

    HeroicGamer Newbie

    Newcomer
    9
    0
    Mar 3, 2017
    Thank you! I'll be sure to try resetting the settings and such. It's great to get a reply so quickly!

    EDIT: Wow! I followed your instructions, and after a simple reboot, the games are now appearing. I can finally play my Mario Kart that disappeared so long ago, thank you so much!
     
    Last edited by HeroicGamer, Jul 22, 2017