I Can't Run Peace Walker UMD On My 5.00 m33-6 psp

Discussion in 'PSP - Games & Content' started by Alex221, Dec 26, 2010.

  1. Alex221
    OP

    Alex221 GBAtemp Advanced Fan

    Member
    602
    21
    Oct 20, 2009
    United States
    Texas
    when i try to run the metal gear solid umd on my 5.00 m33-6 psp 1000,it says "The system software of your psp system is version 5.00. To start you must update to version 6.20 or later. What do i have to do in order to be able to play the game?
     
  2. Law

    Law rip ninjacat that zarcon made me

    Member
    4,132
    217
    Aug 14, 2007
    ‭jerkland
    Rip the ISO from the UMD and patch it with ISOtool

    or update your CFW to something newer
     
  3. Goli

    Goli RPG

    Member
    2,571
    2
    Jul 16, 2008
    Cote d'Ivoire
    Upgrade to Prometheus 4.
    Or update to firmware 6.20.
     
  4. Alex221
    OP

    Alex221 GBAtemp Advanced Fan

    Member
    602
    21
    Oct 20, 2009
    United States
    Texas
    ill upgrade to prometheus 4 and ill see if it works.
     
  5. DigitalDeviant

    DigitalDeviant GBAtemp Addict

    Member
    2,002
    60
    Feb 14, 2010
    United States
    Solar Federation
    it'll definitely work, best cfw so far.
     
  6. easycrashing

    easycrashing GBAtemp Regular

    Member
    149
    12
    Nov 30, 2010
    United States
    Prometheus or extract it to ISO and patch manually.
     
  7. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Mind explaining exactly why, because that seems like a noob statement if ever there was one....
     
  8. Kamiyama

    Kamiyama GBAtemp Fan

    Member
    485
    24
    Mar 14, 2007
    Finland
    Yeah, you can play from UMD with Prometheus 4 and so far every game is working without need to update the firmware. I'm using it and playing my UMD games without problem. Including Peace Walker.
     
  9. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    7
    Mar 20, 2010
    Netherlands, currently
    I'd say it's the best patch so far, cause it's not really a CFW.
    It's your choice if you install it on 5.00m33 or 5.50 Gen-d3