Question How good is N64 emulation on the Switch?

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by Ralph1611, Aug 27, 2018.

  1. Excitedguy

    Excitedguy Member

    Newcomer
    3
    Oct 21, 2006
    United States
    Has anyone noticed in Super Mario 64, objects seem to disappear when not that far from them? Talking things like trees, coins, etc. Is the draw distance normally that low or do I to turn on a certain setting to prevent that from happening. Honestly can't remember if it's normal or not. You can easily see this on the first stage.
     
  2. Billy Acuña

    Billy Acuña GBAtemp Addict

    Member
    11
    Oct 10, 2015
    Mexico
    Guys, the launching method (album, nsp or the recommended one title redirection) does not have nothing to do with the performance, mupen64plus-next does not even boot roms if you launch it using the album applet to being with, if performance isn't great for you, delete retroarch_core_options.cfg and/or fix your settings, start from fresh RA installation may help too.
     
    TeddyBearYoshi likes this.
  3. Josshy0125

    Josshy0125 GBAtemp Regular

    Member
    4
    Jun 16, 2019
    United Kingdom
    It boots them for me...
     
  4. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    Unless things changed since I played through it (which matched what I read about it at the time), Mario 64 will MOSTLY run fullspeed without overclock. There are certain areas like the submarine which need overclock to be fullspeed. I wouldn't expect lag all the time without overclock, unless something significant changed with the emulation in the last couple of months.

    You should notice it actually just happens in the "widescreen" area at the sides of the screen. The game isn't programmed to use that area properly so objects get cropped to the 4:3 area. IDK if there are any cheat codes to adjust that, but if not you can either live with it or set the screen display to 4:3 and have black bars at the sides instead.
     
  5. 2Siralv

    2Siralv Advanced Member

    Newcomer
    3
    May 12, 2018
    Canada
    Would anyone here watch someone who eould do indepth tuts on every emu avalibe or cfw etc eith great detail? Or is thier enough of that on yt and here?
     
  6. silvershadow

    silvershadow GBAtemp Regular

    Member
    6
    May 16, 2006
    Canada
    I wouldnt waste my time watching a video, but i would read a written tutorial. More value for me (my opinion ofcourse).
     
  7. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    I got it working fullspeed through Lakka only. Did you run it through retroarch from hbmenu or Lakka?
     
  8. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    hbmenu.
     
  9. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    Weird though. So what do I actually do wrong? Why does it run like this? It runs like 40-50 fps when playing. The sound also stutters
     
  10. 2Siralv

    2Siralv Advanced Member

    Newcomer
    3
    May 12, 2018
    Canada
    Okay well like yt would be showing it i gusse but okay ill give that a thought i have alot of things working and even android that ppl strugling on and i wanna help
     
    silvershadow likes this.
  11. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
    Go "Help -> Send Debug info", post your ID here.
     
  12. silvershadow

    silvershadow GBAtemp Regular

    Member
    6
    May 16, 2006
    Canada
    Remember, everyone is different. Some people cant read and comprehend as well as others, videos might be better for them to follow along with.

    The downside to videos i see often though is that methods change overtime. Its easy to update a text guide, but harder to update a video guide.
     
  13. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    Send it to them but I couldn't write the code down fast enough. Now when I do it again it won't connect to their servers....WHY/?

    — Posts automatically merged - Please don't double post! —

    It says fail to send to debug server

    — Posts automatically merged - Please don't double post! —

    Ok I solved that. Had to wait a bit. The code 24087
     
  14. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
    Set your audio driver to "switch_audren_thread", set "Audio Latency" to 85ms, turn on "Video Threaded", restart RetroArch.
     
  15. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    Will try that ! Thanks
     
  16. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    Only had switch thread. Also did the otber settings. It still lags on title screen with the mario face...
     
  17. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
    Update your RetroArch including all cores.
    Could also be u changed some core option :shrug:
     
  18. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    What is the latest version? And how can I update my cores?
     
  19. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
  20. HappehLemons

    HappehLemons Member

    Newcomer
    2
    Jan 24, 2011
    United States
    This is not normal. Mario 64, as well as many other games work perfectly without overclocking. Goldeneye has been the only game so far I have needed to overclock for
     
    CrazyRach82 likes this.
  21. gabisenk

    gabisenk Advanced Member

    Newcomer
    1
    Nov 19, 2017
    Romania
    Yes it ain't but the console itself can't be the problem. I run lakka games pretty smooth up to dreamcast with playable speeds.
     
Quick Reply
Draft saved Draft deleted
Loading...