How do you update Luma3DS?

Discussion in '3DS - Homebrew Development and Emulators' started by Xcyper33, Jun 23, 2017.

  1. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
  2. kikongokiller

    kikongokiller Custom Title

    Member
    173
    252
    Jan 12, 2017
    Australia
    Western Australia
    "Always copy boot.firm to the root of the SD. You don't need to do anything else if you're using boot9strap." It did tell you something.
     
    Quantumcat likes this.
  3. GameInCanada

    GameInCanada GBAtemp Regular

    Member
    117
    58
    Feb 18, 2017
    Canada
    Are you on a9lh and luma 7.0- 7.0.5?
    Or a9lh and luma 6.6?

    Or
    Are you on boot9strap 1.0 and 7.1 and are trying to get to luma 8.0?

    If none of these please explain a bit more.
    Normally you use luma updater, but currently the newest version of luma is 8.0 which requires boot9strap which replaces a9lh.
    Luma 8.0 has to be installed manually afterwords

    If youre on 6.6-7.0.5 you can just download the version of luma you wana update to aslong as its under 7.1 and put the arm9loaderhax.bin on your sd card root and it will be updated
     
    Last edited by GameInCanada, Jun 23, 2017
  4. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
    I'm still on 6.3.1 though. Thats not the latest Luma3ds update is it? I'm missing key options that I want to have access to (particularly gamepatcher)

    — Posts automatically merged - Please don't double post! —

    I'm on 6.3.1 actually. And I use arm9loadhax
     
    Last edited by Xcyper33, Jun 23, 2017
  5. GameInCanada

    GameInCanada GBAtemp Regular

    Member
    117
    58
    Feb 18, 2017
    Canada
    Thats a pretty old version of luma im not sure if potentially this would mean your a9lh is outdated? Did you get cfw after November 2016?

    If you wanted to try you could rename "arm9loaderhax.bin" on your sd card to "Arm9loaderhax.bin.bak"

    Then replace it with say version 7.0.X of luma and see if you boot
     
    Last edited by GameInCanada, Jun 23, 2017
  6. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
    err okay. Hmm I'll give it a try
     
  7. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
    Where do i get 7.1 luma3ds?

    — Posts automatically merged - Please don't double post! —

    "An error occrued whole loading the payload. Press key to continue"

    So No. Replacing my armloader with boot.bin made it so it doesn't boot. (I was holding start at beginning btw)
     
  8. WeedZ

    WeedZ Possibly an enlightened being

    Member
    GBAtemp Patron
    WeedZ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,715
    5,244
    Jan 13, 2015
    United States
    The latest versions of Luma don't support a9lh. 7.0.5 is that latest you can use.

    https://github.com/AuroraWright/Luma3DS/releases
     
  9. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
    Is this as simple as placing all contents of the zipped file into directory?


    Because the way the Zip file is set up is different from the way my sd card root directory looks. I do not have a "hax" or "menuhax" or mset/mset-spider" folder in my directory. But some of these folders do have files that are inside of my directory but placed in different folders.
     
    Last edited by Xcyper33, Jun 23, 2017
  10. WeedZ

    WeedZ Possibly an enlightened being

    Member
    GBAtemp Patron
    WeedZ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,715
    5,244
    Jan 13, 2015
    United States
    Just the arm9loaderhax.bin
     
  11. WeedZ

    WeedZ Possibly an enlightened being

    Member
    GBAtemp Patron
    WeedZ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,715
    5,244
    Jan 13, 2015
    United States
  12. Xcyper33
    OP

    Xcyper33 GBAtemp Regular

    Member
    202
    12
    Oct 2, 2007
    United States
    yes i got it updated. Incase I want to move to 7.1+, any clear tutorials for that?

    (Thanks btw, much appreciated!)
     
  13. GameInCanada

    GameInCanada GBAtemp Regular

    Member
    117
    58
    Feb 18, 2017
    Canada