Homebrew games won't work

Discussion in 'Wii - Emulation and Homebrew' started by Falligrecht, Dec 21, 2016.

  1. Falligrecht
    OP

    Falligrecht Member

    Newcomer
    14
    0
    Dec 19, 2016
    Gambia, The
    Hello!

    I'm new to this forum, and I started by posting in this thread: https://gbatemp.net/threads/guide-t...ost-compatibility-issues.394397/#post-6935235

    Maybe it was wrong, but I assumed that the problem could be solved by updating my softmod Wii to all latest IOS version.

    Still I have the same problem:
    When I start Secret Mario Chronicles or eduke32 I just get a black screen. The Wii is frozen and I have to push the power button for some seconds to restart the Wii.

    Here's my Sycheck log again:

    Syscheck HDE 2.4.0

    Most tools I have tried are working fine, like Multimod or even some Homebrew tools like WiiXplorer.
    But those homebrew games just won't.
    Could you please help me?
     
  2. SamThiiSaminator

    SamThiiSaminator That one kid who bricks everything

    Member
    128
    31
    Dec 14, 2016
    United States
    West Sussex, England
    Analyse the syscheck with ModMii. The command from the menu is 'su'.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,038
    8,554
    Oct 27, 2002
    France
    Engine room, learning
    homebrew games don't need modmii nor custom IOS installation, so it's not linked to your issue. Some (last released) homebrew only need IOS58 to access the devices (sd/USB/NAND/controllers/etc.)
    But your reports looks fine. you already have the correct cIOS, and I think latest official IOSes.

    the issue is probably something else.
    For example, are you launching them from USB or SD? some homebrew might have SD path hardcoded. (I don't remember if all homebrew were working on both SD and USB, that's just an idea)
     
  4. Falligrecht
    OP

    Falligrecht Member

    Newcomer
    14
    0
    Dec 19, 2016
    Gambia, The
    I have now set all to reside on USB, as I'm using NAND Emulation. This actually fixed Mario. But most homebrew games till won't work. Even the Homebrew Browser iself won't work (Cannot create directory), although I have set all it's related options to USB path.