1. PhyniXsw

    OP PhyniXsw Newbie
    Newcomer

    Joined:
    Jan 21, 2021
    Messages:
    5
    Country:
    Germany
    I want compile a HomebrewApp but i have a lot of errors
    i hope anyone can help me

    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lglfw3
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lEGL
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lglapi
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -ldrm_nouveau
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lcurl
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lz
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lmbedtls
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lmbedx509
    c:/devkitpro/devkita64/bin/../lib/gcc/aarch64-none-elf/10.2.0/../../../../aarch64-none-elf/bin/ld.exe: cannot find -lmbedcrypto
    collect2.exe: error: ld returned 1 exit status

    i have test follow libs to install with follow command pacman -S switch-glfw3 .....
     
  2. Windi

    Windi Member
    Newcomer

    Joined:
    Nov 21, 2019
    Messages:
    19
    Country:
    Germany
    It would be helpful if you could give some more information:
    -which homebrew app are you trying to install?
     
  3. PhyniXsw

    OP PhyniXsw Newbie
    Newcomer

    Joined:
    Jan 21, 2021
    Messages:
    5
    Country:
    Germany
    I want compile aio-switch-updater
    with a windows 10 pc
    i have devkitARM and devkitA64 installed
     
  4. Homlet

    Homlet GBAtemp Regular
    Member

    Joined:
    Feb 28, 2020
    Messages:
    298
    Country:
    France
    you need to install those dependencies.
    Code:
    sudo (dkp-)pacman -S switch-glfw \
    switch-glm \
    switch-mbedtls \
    switch-zlib
    
    https://github.com/devkitPro/pacman-packages/tree/master/switch here you can have a list of all the available devkitpro switch libraries. You may need switch-bzip2 too. I'll try to add build instructions to the readme
     
    Last edited by Homlet, Jan 21, 2021
  5. PhyniXsw

    OP PhyniXsw Newbie
    Newcomer

    Joined:
    Jan 21, 2021
    Messages:
    5
    Country:
    Germany
    Thank you Homlet, i test it later

    Boahh this List of Libs is very helpful thanks you
     
    Last edited by PhyniXsw, Jan 21, 2021
  6. Homlet

    Homlet GBAtemp Regular
    Member

    Joined:
    Feb 28, 2020
    Messages:
    298
    Country:
    France
    I've updated the readme with some build instructions
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Homebrew, compile, error