[HELP] with Texture replacing (MK8 and Mario Maker)

Discussion in 'Wii U - Hacking & Backup Loaders' started by Louiskovskie, Jun 15, 2017.

  1. Louiskovskie
    OP

    Louiskovskie Advanced Member

    Newcomer
    89
    44
    Jul 26, 2016
    Germany
    A lot of hours are gone and all what i got, is NOTHING. I'm trying all the time to replace a texture of Mario Maker with another.

    The first thing i tried is using this tool. But whatever i do, every texture i export with this tool will look like this, and i have no idea why. I don't know, if this tool needs another specific program to work, since there is no readme or something.

    Then later i followed this tutorial, and got the dds texture file correctly and edited it for testing, but when i click on filelist.bat, a window will appear for 0,001 seconds and then disappears, though i made it exactly like in the tutorial and there is also "pause" at the end of the bat. And i also have phyton installed and even reinstalled it, and nothing changed. But before i gave up, i simply opened cmd and entered the contains from the bat there, and then it worked and displayed anything i need. The texture position is simple "00".

    But then appeared the next problem: The next bat i have to create, named "splicer.bat", do the same thing like filelist.bat. It displays a window for a millisecond and then disappears. So i used cmd again and what it displays is just the Usage from the author of the program, how to use it. That's it. The text i'm entering for the cmd is "hax.py mw_field_plain.dds MW_Field_plain.bfres 0 position pause". It only displayed anything, when i removed "position pause" and added a "00" at the end, like this: "hax.py mw_field_plain.dds MW_Field_plain.bfres 0 00". Then i got this:

    BFRES mips: 0
    GTX mips: 0

    According to the tutorial, i have to note the mips and replace the 0 in the bat with it and run the bat again. However, the mips actually is already 0. Then i have to note the GTX mips, which is again... 0? and enter these two values to the end of the splice.bat file. So i entered "hax.py mw_field_plain.dds MW_Field_plain.bfres 0 0", but the result i get, is either an error message or a very large bfres file, which just crashes the Wii U. I also got an mw_field_plain1.gtx file and the tutorial says, that when i got this file, anything should be fine. However, it isn't :(

    So can someone help me? I would be soo thankfully, since i wasted hours for nothing!

    Thanks in advantage
     
  2. Don Jon

    Don Jon GBAtemp Fan

    Member
    468
    181
    Nov 20, 2015
    United States
    Can you upload something you exported.

    Maybe the paint program u r using does not read. Dds files correctly.