HELP with DSTTi for NDSi XL

Discussion in 'DSTT' started by TelCom, Sep 26, 2010.

  1. TelCom
    OP

    TelCom Newbie

    Newcomer
    2
    0
    Sep 26, 2010
    I just bought a NDSi XL and DSTTi few days ago. The DSTTi software was pre-installed in the SD card. It worked the first time I put it in my NDSi XL, but the next day it didn't work - keep getting this msg "An error has occured. Press and hold......". I've googled the web for solutions but still can't get the thing to work. It load fine on my old NDS - but not on my new DSi XL. Could someone help me out here? What should I do?? [​IMG]
     
  2. 0ddity

    0ddity GBAtemp Fan

    Member
    438
    0
    Aug 7, 2010
    Canada
    Ontario
    Looks like you updated to 1.4.1 firmware, there is no fix for DSTTi.
     
  3. Slyakin

    Slyakin See ya suckers

    Member
    4,450
    40
    Oct 15, 2008
    United States
    Soviet Slyakin
    There is a solution:

    Go to Shoptemp.
    Browse DS Flashcarts.
    Choose AceKard2i/SCDSTwo
    Buy it.
     
  4. TelCom
    OP

    TelCom Newbie

    Newcomer
    2
    0
    Sep 26, 2010
    serious? so is 1.4.1 different to 1.4?
    So i guess i have to buy another card then... so AceKard2i will definitely work with DS XL?
     
  5. 0ddity

    0ddity GBAtemp Fan

    Member
    438
    0
    Aug 7, 2010
    Canada
    Ontario
    Yes 1.4.1 is different than 1.4, note the .1. New features include bricking most flash carts. Yes, Acekard 2i works on 1.4.1 if it's been updated to work with the fix. You need a DSi on 1.4 or a DS phat or lite to update the card though, or if you buy the cart and a TF from shoptemp, they will do it for you for a small fee.
     
  6. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    This is the "premium update/flashing service".