Help with a possibly mail-bricked Wii

Discussion in 'Wii - Hacking' started by NooBrewer, Jul 18, 2014.

  1. NooBrewer
    OP

    NooBrewer Newbie

    Newcomer
    3
    0
    Jul 18, 2014
    Brazil
    O hai

    I was looking for some place to get help, and seems like you guys are still active on wii modding.
    I did some searches trying to get info to do a quite challenging fix on a Wii, but I found a lot of outdated things (or things I couldn't tell it's outdated due to my noobish).

    So, I would be most thankful if you help me with this ^^

    The tl;dr version:

    - 4.3U Wii goes do black screen after "Health and safety" screen. Works fine on maintenance mode. Sounds like a mailbox brick.
    - SD card slot cannot be used - maybe it's dead, no SD card is accepted. HBC runs things from a FAT32 partition on a external USB Hard Drive.
    - I don't know the state of the Wii modding - I know HBC is available, and bootmii is also installed as IOS. Can't tell the state of the rest.

    Now, explaining things better,

    This Wii came to me (actually, to my nephew) already softmodded. This is why I don't know the real state of the changes made on it. It had already installed Homebrew Channel, bootmii as IOS, USB Loader GX and came with a external HD with a FAT32/WBFS split.
    It's on 4.3U, but I don't even know if it already was on this version when first modded or the kid updated it later from Nintendo while poking things he doesn't know.

    I don't know the state of any anti-brick stuff - bootmii as boot2 and stuff.
    I guess it don't have Priiloader because holding reset at startup doesn't do nothing.

    Ok, the system was running fine until problems started to appear.
    First, USB Loader started to crash (DSI exception). I tried updating it but, again, I couldn't tell the original way of modding (USB Loader as full channel or just a forwarder).
    The time I tried updating it, I found the SD slot also dead.

    After struggling a little before convincing myself that SD slot has passed away (using another SD card, loading the cards on other devices, all the standart checks), I tried to run a updated USB Loader Gx from the FAT32 partition on USB HDD, via HBC, and it works. Games can now be played relatively well. The old broken USB Loader channel is still there, but I'm just ignoring it and running the newer from USB via HBC.

    Now, the last problem is the mailbrick (or at least I think it is).
    The system works good with maintenance mode and it can even play games via the way I described above. But it won't start the normal way.
    I tried the Det1re's method, but it kept giving me just a DSI exception - and I guess I was lucky, cause I should never have tried it before ensuring there's a safe anti-brick protection properly installed.

    The other way to fix, accordingly with I've read, is formatting everything.
    To do this, I have to first backup the NAND via bootmii - wich I don't know how to do without the SD slot (maybe the HD can be used?).
    Also, after formatting, I'll need to reinstall HBC and other stuff, and I need to have Priiloader or bootmii as boot2 - and I don't know if this stuff is there. And I'm afraid of trying to install, and installing it on a fresh system is not the same as installing on a already softmodded system, and I may ending up bricking the Wii for good.

    This is where I'm stuck now:

    - Figuring out the current state of this Wii's modding (so I can safely install or update what's needed)
    - Installing proper anti-brick protection (using only the FAT32 partition on USB HDD, since SD is gone)
    - Fixing the mailbrick
    - In case of any fix fails, format the nand (ensuring I can put everything back properly).

    Any help will be greately appreciated.
    Thanks for reading =)
     
  2. gudenau

    gudenau Largely ignored

    Member
    GBAtemp Patron
    gudenau is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,286
    1,252
    Jul 7, 2010
    United States
    /dev/random
    I do know to much in the way of brick resolving.
    I do however know that 4.3 is fully softmodable.
    Can you boot into bootmii? If you can then that means the sd card works, but there is some weird stuff going on with ios.

    Maybe you could exchange the wii.

    Edit:
    Maybe you could run the update softmods option in ModMii.
     
  3. NooBrewer
    OP

    NooBrewer Newbie

    Newcomer
    3
    0
    Jul 18, 2014
    Brazil
    Thanks for the quick response ^^
    Sorry to only look on this again after a while, but I was poking on the Wii on this time.

    This advice made a huge difference: I was able to diagnose the SD Card slot via bootmii.
    And, I found out the SD card works only when it wants =(
    Sometimes it loads, majority of the times it doesn't.
    I guess I can't count on it anyway.

    Well, I checked out ModMii and I was able to update all softmod on the console.
    Now I have bootmii and HBC updated, and while I was not able to install bootmii on boot2 (Hackmii detected it's not possible), I managed to get Priiloader. And I was lucky that the SD worked for getting a nand backup from bootmii.

    Now I got my life preserver, I went into solving the mailbox brick.
    And I didn't suceeded.

    I tried it two ways. Both of them was using WiiXplorer to write the nand, since FSToolbox needs to get data from SD aaaand... well...
    WiiXplorer can read USB too, so it's my weapon of choice(?) now.

    I did:

    - First, i tried the Det1re's way. I got his/her replacement to the files stored on nand/shared2/wc24/.
    Made backup first, of course.
    Tried starting the Wii, no good.

    - Secondly, I tried this method to replace the cdb.vff stored on nand/title/00000001/00000002/.
    It said this file holds all the messageboard data, and I followed the steps to get myself a clean version of the file.
    Tried starting the Wii, no good.


    In both cases, I enabled the NAND Write Mode on WiiXplorer.

    The console still works on maintenance mode.
    And now I'm stuck again. =(
     
  4. gudenau

    gudenau Largely ignored

    Member
    GBAtemp Patron
    gudenau is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,286
    1,252
    Jul 7, 2010
    United States
    /dev/random

    Try https://sites.google.com/site/completesg/other-stuff/virgin
    If this does not help, that is the best I can do.
     
  5. VashTS

    VashTS Beat it, son

    Member
    GBAtemp Patron
    VashTS is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,932
    714
    Mar 14, 2009
    United States
    Upstate NY
    grab priiloader and Wiimod. put them on a usb drive since the SD is picky.

    next, grab a full system update (system menu and IOS) from NUSD or ModMii. while you are at it, grab the cIOS you prefer from ModMii(d2x beta10). put them on the USB drive.

    boot into HBC, load Wiimod. Install all the wads mentioned above. Go back to the HBC. Install Priiloader. Boot up again and see if she works.
     
  6. NooBrewer
    OP

    NooBrewer Newbie

    Newcomer
    3
    0
    Jul 18, 2014
    Brazil

    Thanks for the advices =)
    But I'll think I'll look for some alternatives before trying this: it says there it's a very dangerous thing to try, and it's just a corruptd mail, it seems...

    But thanks anyways =)


    I already managed to get Priiloader working from ModMii.
    All it remains now it the mailbox brick problem. Maintenance mode still starts fine.

    But I'll do a closer look on this full system update - when I used ModMii, I just choose the recommended wads and choose to not modify any existent IOS (except for 236 that is required for Priiloader).