1. Lazardo

    OP Lazardo Member
    Newcomer

    Joined:
    Feb 27, 2019
    Messages:
    12
    Country:
    Portugal
    Hello,

    I got a 2nd hand Switch on a semi brick state, it's on auto rcm, I can inject payloads on it but it doesn't boot either OFW or CFW.

    I have been following the guide How to install/run ANY Switch firmware UNOFFICIALLY (WITHOUT burning any fuses) up until STEP 7: GENERATE the files/images to be transferred to the console via ChoiDujour

    On that step I get:
    ChoiDujour 1.1.0 by rajkosto
    uses hactool by SciresM (xxxxxxx)
    visit xxxxx for updates and more Switch stuff!

    Using source firmware files from folder Firmware
    Traceback (most recent call last):
    File "ChoiDujour.py", line 517, in <module>
    File "ChoiDujour.py", line 225, in call_hactool
    Exception: [WARN]: Failed to match key "master_kek_04", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
    [WARN]: Failed to match key "master_kek_05", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
    [WARN]: Failed to match key "master_kek_02", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
    [WARN]: Failed to match key "master_kek_03", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
    [WARN]: Failed to match key "master_kek_00", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
    [WARN]: Failed to match key "master_kek_01", (value "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx")

    I have edited the keys file, removed the master_kek_* entrys and got:
    ...

    Everything is Ok

    Size: 1146880
    Compressed: 22709
    Verifying file SYSTEM/save/8000000000000120
    All files verified! Prepared firmware update is in folder E:\ChoiDujour110\NX-6.1.0_exfat

    But the folder e:\ChoiDujour110\NX-6.1.0_exfat\SAFE is empty, which makes me believe that something is wrong. I have checked the SAFE partition on the emmc and it is also empty.
     
  2. Sucuk60

    Sucuk60 Member
    Newcomer

    Joined:
    Dec 1, 2018
    Messages:
    38
    Country:
    Germany
    I downgraded my Switch too and the folder SAFE was empty :)
     
    Lazardo likes this.
  3. Lazardo

    OP Lazardo Member
    Newcomer

    Joined:
    Feb 27, 2019
    Messages:
    12
    Country:
    Portugal
    When you mount the SAFE folder wjth
    When you mount the SAFE folder with HacDiskMount is it also empty (mine is...)
     
  4. Philliyxx

    Philliyxx GBAtemp Fan
    Member

    Joined:
    Sep 21, 2018
    Messages:
    311
    Country:
    United States
    I've downgraded with SAFE folder empty as well.
     
  5. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia

    This is fine, you can continue the process
     
  6. Lazardo

    OP Lazardo Member
    Newcomer

    Joined:
    Feb 27, 2019
    Messages:
    12
    Country:
    Portugal
    I did it and it's still bricked, the only clue that I have is that the on the console the SAFE folder is empty, the previews owner mus have erased it, is there any way to get/build the contents of that folder?
     
  7. PrEtZaL

    PrEtZaL Advanced Member
    Newcomer

    Joined:
    Nov 13, 2018
    Messages:
    85
    Country:
    United Kingdom
    This is not your problem the SAFE partition can be empty. How far through the boot process do you get?
     
  8. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    I can assure it is okay if the safe folder is empty.

    try the rest of the process again, if it doesn't boot I suspect they attempted a manual downgrade and formatted the nand
     
  9. PrEtZaL

    PrEtZaL Advanced Member
    Newcomer

    Joined:
    Nov 13, 2018
    Messages:
    85
    Country:
    United Kingdom
    As long as they didn't mess up the boot files and prodinfo it should be recoverable. Also try using hekate 4.6 with the custom kip and hekate file from choidujour. I had issues with 4.8 on a downgrade, but work fine after 1st boot
     
    Last edited by PrEtZaL, Feb 27, 2019
  10. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    Boot files dont matter when doing the downgrade.. prod info does.... I suspect the original owner might have attempted a downgrade and clicked format
     
  11. PrEtZaL

    PrEtZaL Advanced Member
    Newcomer

    Joined:
    Nov 13, 2018
    Messages:
    85
    Country:
    United Kingdom
    No they won't matter on downgrade, although if they're buggered it won't boot.

    If they formatted should be able to see by using a hex editor
     
  12. Lazardo

    OP Lazardo Member
    Newcomer

    Joined:
    Feb 27, 2019
    Messages:
    12
    Country:
    Portugal
    I will assume that they did that, is there any way to recover it?
     
  13. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    again re-try the downgrade/rebuild process, let me know how it goes, if it fails to boot again message me as I have something I wish to try
     
  14. PrEtZaL

    PrEtZaL Advanced Member
    Newcomer

    Joined:
    Nov 13, 2018
    Messages:
    85
    Country:
    United Kingdom
    If they formatted the boot file partitions without a backup then no.......
     
  15. Lazardo

    OP Lazardo Member
    Newcomer

    Joined:
    Feb 27, 2019
    Messages:
    12
    Country:
    Portugal
    I did that several times with the Firmware 6.1.0 (checked the burnt fuses and rawnand and they match)
     
  16. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    Message me on discord, it will be quicker and easier but I can think of one thing that *might* and that is a veeery big might help
     
  17. Sucuk60

    Sucuk60 Member
    Newcomer

    Joined:
    Dec 1, 2018
    Messages:
    38
    Country:
    Germany
    Your problem is you created the fw folder in Choi with exfat support!
    In Choi you should type: the command —noexfat

    That was my problem.
     
  18. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    how is exfat the problem
     
  19. Sucuk60

    Sucuk60 Member
    Newcomer

    Joined:
    Dec 1, 2018
    Messages:
    38
    Country:
    Germany
    My problem was exfat support. First time I downgraded it with Choi (5.1 exfat) and then the switch still had a blackscreen. As I tried it without exfat support on fw 5.1 (because I read it here) .. everything worked fine.

    Sorry for my english!
     
  20. Adran_Marit

    Adran_Marit Walküre's Hacker
    Member

    Joined:
    Oct 3, 2015
    Messages:
    3,035
    Country:
    Australia
    Odd, you're the first person I've seen with that issue. No one else I know who's done this has had a problem with the exfat support
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - unbrick, trying,