[Help needed] How do I update Luma on 11.4?

Discussion in '3DS - Homebrew Development and Emulators' started by IggyJet, Jun 4, 2017.

  1. IggyJet
    OP

    IggyJet Advanced Member

    Newcomer
    63
    14
    Jan 8, 2017
    Brazil
    Greetings.

    Apologies if this is repetitive, I can't seem to find an answer for this specially because it's been a while since I've updated Luma (or anything hack related).

    Okay, my system is currently at 11.4 (I hacked it on 11.3 with soundhax/a9lh) and when I try to update Luma (which is at version 7.0.1) it says "Fatal: Could not find arm9loaderhax.bin / FATAL Could not get A9LH payload..."

    I had read something back then that on 11.4 homebrew doesn't work anymore or something like that, I can't quite recall all of it. I didn't do/research anything at the time because I didn't really have much free time.

    So, how do I update Luma now? And how do I access homebrew launcher again (if possible) on 11.4? What do I need to replace?

    Any links would be very appreciated.

    Thank you for your help!
     
  2. trainboy2019

    trainboy2019 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    761
    212
    Oct 6, 2015
    Antarctica
    Ylisse
    Are you on a9lh or boot9strap?
     
  3. IggyJet
    OP

    IggyJet Advanced Member

    Newcomer
    63
    14
    Jan 8, 2017
    Brazil
    a9lh, I don't know what boot9strap is yet (sorry, like I said it's been a while). I haven't upgraded anything hack-related after I updated to 11.4, so it's still pretty much all the stuff that worked on 11.3.
     
  4. trainboy2019

    trainboy2019 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    761
    212
    Oct 6, 2015
    Antarctica
    Ylisse
    I see. In short, Boot9Strap replaced a9lh, luma no longer supports a9lh. Follow this guide to upgrade.
     
    IggyJet likes this.
  5. IggyJet
    OP

    IggyJet Advanced Member

    Newcomer
    63
    14
    Jan 8, 2017
    Brazil
    Thank you so much, it worked like a charm. Could I bother you a little more though? Now that I'm on boot9strap, is there a way to use Homebrew Launcher again?
     
  6. trainboy2019

    trainboy2019 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    761
    212
    Oct 6, 2015
    Antarctica
    Ylisse
    Yes, what system are you on?
     
    IggyJet likes this.
  7. IggyJet
    OP

    IggyJet Advanced Member

    Newcomer
    63
    14
    Jan 8, 2017
    Brazil
    Old 3DS XL, 11.4.0-37U
     
  8. TheDarkGreninja

    TheDarkGreninja How could you hate that face?

    Member
    2,243
    946
    Aug 25, 2014
    On his bed
    Homebrew Channel wont work on o3ds as far as I know, but it does work on n3ds.
     
  9. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,871
    3,133
    Mar 16, 2012
    United States
    It works on 11.4 on o3DS if you have Luma. You just have to use the 11.2 payload instead.
     
    IggyJet likes this.
  10. trainboy2019

    trainboy2019 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    trainboy2019 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    761
    212
    Oct 6, 2015
    Antarctica
    Ylisse
    Follow the steps that say "OLD 3DS and 2DS ONLY" here
     
    IggyJet likes this.
  11. TheDarkGreninja

    TheDarkGreninja How could you hate that face?

    Member
    2,243
    946
    Aug 25, 2014
    On his bed
    oh didnt know that.
     
  12. IggyJet
    OP

    IggyJet Advanced Member

    Newcomer
    63
    14
    Jan 8, 2017
    Brazil
    You're amazing. It worked. Thank you so so much for your help, really. You're the best!!!

    Thanks @KunoichiZ as well! :)
     
    trainboy2019 and KunoichiZ like this.