Help me bros

Discussion in 'Computer Software and Operating Systems' started by Feras2002, Jul 21, 2016.

  1. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
    Why is my windows detecting the wrong gpu which is amd r9 m375 4gb but Windows is detecting it as amd Radeon HD 8800
    ANY HELP
     
  2. FaTaL_ErRoR

    FaTaL_ErRoR AKA ŦƕƎ ƠṀƐƝ

    Member
    491
    346
    Mar 9, 2014
    United States
    Go download the correct driver.
    http://support.amd.com/en-us/download#
    Obviously windows didnt have your driver pre packaged. You may want to check the rest of your stuff to ensure the correct drivers are running your components.
     
  3. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
    The problem is I can't download it from my amd website...if u can give me a direct link and post it here it will be good I guess if u don't mind
     
  4. Dr_Doom

    Dr_Doom Advanced Member

    Newcomer
    95
    28
    Mar 10, 2016
    FaTaL_ErRoR likes this.
  5. FaTaL_ErRoR

    FaTaL_ErRoR AKA ŦƕƎ ƠṀƐƝ

    Member
    491
    346
    Mar 9, 2014
    United States
    Dr_Doom likes this.
  6. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
  7. FaTaL_ErRoR

    FaTaL_ErRoR AKA ŦƕƎ ƠṀƐƝ

    Member
    491
    346
    Mar 9, 2014
    United States
    Dr Doom posted it first you should change who you thanked. But, no problem.
     
  8. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
    FaTaL_ErRoR likes this.