[Help] How to upgrade to 2.5?

Discussion in '3DS - Homebrew Development and Emulators' started by Itachi_hoshigaki, Oct 26, 2015.

  1. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    I'm having lots of trouble trying to update my HBL version! My entrypoint right now is ThemeHax; It appears that none of the new features from 2.5 are working on my N3DS 9.9.....

    I Downloaded the files from Smealum's HBL page, and just copied them to the root of my SD and replaced everything it asked me to replace; Did I do something wrong? What can I do to fix it?

    Oh, and btw I already downloaded the ropbin for my N3DS FW version, and it still does not work!
     


  2. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    When you were using ThemeHax with 2.1, did you have a menuhax ropbin payload .bin at the root of your SD card?
     
  3. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    Yes, I did, and nothing happened; Everything stayed just the same.
     
  4. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,953
    Jun 9, 2007
    Antarctica
    That's because you need to update the payload manually. Go to https://smealum.github.io/3ds/ and download the "ropbin" version of the payload that's appropriate for your firmware, then put it on your SD card, and rename it to the same thing your themehax file was (should be something like ropbin_menuhax_USA_etc.). If you want to be safe, make a backup of the old one before deleting it. I did this to update my N3DS' themehax payload manually, and it worked fine.
     
  5. Abcdfv

    Abcdfv What comes around goes around.

    Member
    1,454
    591
    Dec 24, 2013
    United States
    Smea held L in the video to launch themehax.
     
  6. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    Thank you a lot for trying to help me, but I already solved the problem myself, I just installed everything again from scratch, but with IronHax installer; But one thing I would really like to know is that if it is possible to opeb HBL with ThemeHax, because so far i could not find a way to do so.
     
  7. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    It is possible, because I am doing it.
     
  8. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    Thanks a lot! I will definitely try that.

    I'll let you guys know if it does work for me!

    I know.... I saw the video....:sleep::sleep:
     
  9. darklordrs

    darklordrs GBAtemp Advanced Fan

    Member
    785
    210
    Aug 16, 2015
    United States
    How would I upgrade my Ironhax, then? I'd start a new thread but it seems like a minor thing to figure out.
     
  10. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,953
    Jun 9, 2007
    Antarctica
    As far as I know, you just run the ironhax installer again, and it'll download the payload for 2.5.
     
  11. DarkRioru

    DarkRioru Dream Beeeeeaaaammmm!!!

    Member
    1,969
    421
    Aug 29, 2015
    United States
    looking up at the stars
    has anyone got ironhax to run 2.5??? I installed it but, it still says 2.1
     
  12. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    You will first have to delete the current Ironhax save, then open HBL with ThemeHax or some other entry point and then just run IronHax Installer, that worked for me like a charm! :yaynds:
     
  13. darklordrs

    darklordrs GBAtemp Advanced Fan

    Member
    785
    210
    Aug 16, 2015
    United States
    could I just put my new ironhax into save slot 2 (my ironfall save is in 1, current ironhax is in 3) instead? I don't feel comfortable aiming for another entry point on the risk that it'll break
     
  14. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    Yeah, you can do that, that's what I did too lol! I was scared of losing my entrypoint....
     
  15. DarkRioru

    DarkRioru Dream Beeeeeaaaammmm!!!

    Member
    1,969
    421
    Aug 29, 2015
    United States
    looking up at the stars
    the themehax installer isn't working!!! it reads: Invalid HTTP content-size: 0x0000a468. install failed: 0xfffffffd
     
  16. darklordrs

    darklordrs GBAtemp Advanced Fan

    Member
    785
    210
    Aug 16, 2015
    United States
    got it working! Praise the sun!
     
  17. DarkRioru

    DarkRioru Dream Beeeeeaaaammmm!!!

    Member
    1,969
    421
    Aug 29, 2015
    United States
    looking up at the stars
    why won't It work damn it!!!! :cry:
     
  18. Itachi_hoshigaki
    OP

    Itachi_hoshigaki Member

    Newcomer
    45
    3
    Jul 4, 2013
    Mexico
    Brownsville, Texas
    That also happened to me.... Try the ropbin thing http://smealum.github.io/3ds/
     
  19. enhasa

    enhasa Member

    Newcomer
    44
    8
    Mar 10, 2013
    United States
    Doesn't work. What'd you name your file? I've tried menuhax_ropbinpayload.bin and themehaxinstaller_otherapp_payload.bin
    9.9.0.26U
     
  20. Leoderas

    Leoderas Member

    Newcomer
    17
    1
    Sep 2, 2015
    Damn just erased my ironfall save file and I'm on the 10.2 patch, tubehax was patched. is there other way of installing ironhax in 10.2?
     
    Last edited by Leoderas, Oct 26, 2015