Help getting USB loader GX and Gamma to run

Discussion in 'Wii - Backup Loaders' started by DatCrossGuy, Jun 1, 2015.

  1. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    Hello everyone, I'm currently encountering issues when trying to get these two to work. For USB loader, when I try to start the app from the homebrew channel I get a black screen and am forced to restart my wii. For Gamma when I try to load the disc I get error 002. Below is my syscheck

    SysCheck v2.3.2 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS36 (rev 1042).

    Region: NTSC-U
    System Menu 3.2U (v289)

    Could not detect the drive date!
    Homebrew Channel 1.0.1 running on IOS36

    Hollywood v0x11
    Console ID: 111246535
    Console Type: Wii
    Shop Channel Country: Jamaica (34)
    Boot2 v3
    Found 53 titles.
    Found 22 IOS on this console. 1 of them are stub.

    IOS4 (rev 3): Stub
    IOS9 (rev 516): Flash Access
    IOS11 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS12 (rev 6): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS13 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS14 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS15 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS16 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 512): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS20 (rev 12): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS21 (rev 514): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS22 (rev 772): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS28 (rev 1288): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS30 (rev 1039): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS31 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS33 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS34 (rev 1039): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS35 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS36 (rev 1042): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS37 (rev 2070): ES Identify
    IOS51 (rev 4633): Trucha Bug
    IOS249 (rev 7): Trucha Bug, ES Identify, Flash Access, NAND Access
    BC v2
    MIOS v5
    Report generated on 05/31/2015.


    Can anyone point me in the right direction to getting these apps to work properly? I figure it has something to do with my IOS, but I can't say I fully understand how this works too well. Thanks in advance.
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,154
    803
    Mar 2, 2015
    United States
    You need to update your system menu and Homebrew Channel first of all. You are missing most of the IOSes required to run anything.

    I would update the system menu then use ModMii to start over from scratch.
     
    DatCrossGuy likes this.
  3. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    I've tried to update my Homebrew channel to 1.2.0 by putting the boot.elf into the apps folder, but all that happens is a screen comes up saying that if I payed for the software I got scammed and it seems like it hangs. This file appears on my SD card after.

    HackMii v1.2 installer starting up
    PVR = 00087200
    running under IOS 37 rev 0x816
    53 titles are installed
    Found IOS 51: revision: 0x1219*
    Found IOS 0: revision: 0x0*
    Found IOS 249: revision: 0x7*
    Found IOS 16: revision: 0x101.
    Found IOS 37: revision: 0x816.
    Found IOS 36: revision: 0x412.
    Found IOS 35: revision: 0x410.
    Found IOS 34: revision: 0x40f.
    Found IOS 33: revision: 0x410.
    Found IOS 31: revision: 0x410.
    Found IOS 30: revision: 0x40f.
    Found IOS 28: revision: 0x508.
    Found IOS 22: revision: 0x304.
    Found IOS 20: revision: 0xc.
    Found IOS 17: revision: 0x200.
    Found IOS 15: revision: 0x101.
    Found IOS 14: revision: 0x101.
    Found IOS 13: revision: 0xa.
    Found IOS 12: revision: 0x6.
    Found IOS 11: revision: 0xa.
    Found IOS 21: revision: 0x202.
    Found IOS 2: revision: 0x121.
    Found IOS 9: revision: 0x204.
    Found IOS 4: revision: 0x3.
    launching IOS 37 for the installer...

    IOS launched...

    IOS versions: Installer: 37, HBC: 0
    starting preparations

    I've tried waiting for over 20 minutes and nothing.


    Would I have to connect to the internet to update my system menu? and which version of the system would I need? I would rather not update it if possible.
     
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,154
    803
    Mar 2, 2015
    United States
    4.3U is the latest version of the menu for your console. You should either be able to update it online or you might try checking in the tutorial forum and see if there's an offline update post.

    The only way to update the HBC that I know of is either to reinstall it with HackMii or let it update on its own, but it may not be able to do that if you're still using an old system menu.

    The scam warning screen is supposed to be dismissible by pressing one of the number buttons on the remote but it does make you wait for at least 30 seconds before you can press the button.
     
  5. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    The Wiimote does not respond at all when I'm in that screen, and no prompt comes up that tells me I can press buttons.

    So the best thing to do would be update to 4.3 and then use modMii to re mod my system?
     
  6. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,154
    803
    Mar 2, 2015
    United States
    That would be my bet. Perhaps @Cyan could verify that just a straight update won't cause any problems first, though. As far as I can tell the report you posted indicates that your current IOSes are stock ones but I'm not 100% certain as my Wii already had 4.x on it when I bought it.
     
  7. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    OK. I updated my homebrew channel and I also followed this guide : https://sites.google.com/site/completesg/backup-launchers/installation

    to install a few new cIOS. Sadly it's the same result. Gamma gets error 02 when I try to launch the game and USB loader GX does not even load from the homebrew channel and I instead get a black screen. Not sure what else to try except starting over completely like you said. I'll wait for cyan to make sure it doesn't do any harm. Thanks for your help.
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,558
    8,911
    Oct 27, 2002
    France
    Engine room, learning
    I'm also on 3.2E and everything is working fine!

    Do not update your console or your system menu without understanding what you are doing.
    If you install only the new system menu version you will brick your console because you will miss official IOS dependencies.


    Just know that System menu version does not interfere with homebrew or games you are playing.
    The system menu is an application launched like any other application, you can only have one application in memory at a time.
    If you launch a game, the system menu is unloaded first.
    If you launch a homebrew, the system menu is unloaded too.
    If you launch The homebrew channel, the system menu is not in memory anymore and will not interfer with your homebrew.

    It's exactly the same with IOS files.
    The system menu (3.2) need IOS30 to work.
    the Homebrew channel need IOS58 to work. other IOS (have or miss) will never interfere.
    USBLoaders need IOS249 to work.
    etc.

    What you have:
    HBC 1.0.1 --> it's old, but you said you updated? as long as you have 1.0.7 or newer you are fine for all other setup.
    IOS249 --> very old. it's v7, now loaders need at least v14. Latest version is v21 mod10 (more than 20 version of differences)
    IOS51 --> seems it's patched/altered. I don't know why. maybe you used a homebrew to install that IOS manually to use the eshop? (a wad manager probably)
    Other IOS --> All good.

    What you miss:
    IOS58 --> needed for HBC and a lot of homebrew.
    IOS249 --> you will have to update it.
    That's all ;)

    What you need to do :
    1. Go to HBC and press Home button. check your "current IOS" version. It MUST be IOS58.
    If not, follow step 2 and 3.
    If it's IOS58, skip to step 4.

    2. install IOS58 ! first, important step before doing anything else.
    http://wiibrew.org/wiki/IOS58_Installer
    run this from HBC, and it will install the IOS58.

    3. reinstall HBC by using the hackmii installer.
    It will find IOS58 and will not freeze.

    4. update the IOS249
    Install the d2x cIOS installer in your /apps/ folder
    run it and select this:
    d2x v8
    slot 249
    base 56
    version 21008
    Press A to install from the network.

    when complete, you can exit by pressing Home button.
    lot of tutorial installs more IOS, but only one is needed for the moment.
    Note that I'm choosing v8 instead of v10. latest is not always better.


    5. update the loader
    Download USBLoaderGX from my signature and extract to your /apps/ folder
    delete any files present in Sd:/config/ folder or apps/usbloader_gx/ folder related to USBLoaderGX.
    GXGlobal.cfg
    gamecache.bin
    (that should be enough to delete these two files)

    6. launch the loader
    go to settings>credit >
    look at the top, it should tell you that it's currently running on "IOS249 d2x v8" "IOS base 56"

    You should not have any error 002 anymore.
    Error 2 is fixed by cIOS rev14+
    d2x cIOS is a modded version of rev21 so you should be fine.

    7. still error002?
    if you still have that error, your ISO is probably bad.
    You are probably still using WBFS partition format instead of FAT32 is you still have your Wii at 3.2
    That partition format is really bad and has a bug which corrupt already installed games when adding new one.

    I will recommend to either:
    - reinstall your game to be sure it's clean dump (don't install new game after that one)
    - drop WBFS format and format to FAT32 (you can convert without formating too, but you don't know which games are already corrupted or not)

    There are tools to check game and find if they are good or bad, let's see that later.
     
    GreyWolf and DatCrossGuy like this.
  9. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,154
    803
    Mar 2, 2015
    United States
    Thanks, Cyan. I figured you would be able to tell him what he needed better than me. My console was newer when I started the process originally. :)
     
  10. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    Thank you for the lengthy reply!

    If you read my most recent post, you will see that I have updated the homebrew channel to 1.1.0 and also updated a few cIOS using this link as a guide

    https://sites.google.com/site/completesg/backup-launchers/installation

    but it didn't help anything. The error 002 is not caused from the USB loader, but from Gamma when I try to launch a disc. I'll report back later. Thanks again you two.
     
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,558
    8,911
    Oct 27, 2002
    France
    Engine room, learning
    then skip 4 steps, and go to step 5 to try USBLoaderGX again
    be sure it's a clean update (delete everything if possible, all the folders and configs)

    you could post a new syscheck too, to see what you have now after following the guide.
     
  12. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    Yes I tried both USB loader and Gamma again and it is the same result. The cIOS update in your step 4 is different than the one in the guide though, so I'm thinking that may be whats up. I'll post a syscheck when I get the chance in a few.
     
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,558
    8,911
    Oct 27, 2002
    France
    Engine room, learning
    my step 4 is almost the same.
    installing v8 instead of v10 (which comes in two version : normal or alternative)
    v10 adds more HDD compatibility (you don't need it if v7 worked fine with your drive)
    v10-alt adds USB Port1 compatibility but had some issues.

    but it's installing the same base in the same slot (base56 in slot249, base57 in slot 250).
    I just skipped the slot250 as it's not your current issue. base57 is used for Call of duty game only. not sure you need it. no need to install unneeded IOS

    oh, and my link to the installer contains all the version in one package, no need to care about d2x installation steps.
     
  14. DatCrossGuy
    OP

    DatCrossGuy Newbie

    Newcomer
    7
    2
    Jun 1, 2015
    Jamaica
    Ok, using the USB Loader gx in your sig worked, I guess the version I got was no good. The loader says I'm using IOS 249v10

    Everything seems to be working except it wasn't displaying any Wii games I had on my drive. After checking some setting I found it was only displaying GC games and other channels I already had on my wii(which is displayed invisibly...) and I had to turn on Wii games for them to be displayed. Now everything seems to be working fine.

    Thanks a lot Cyan and GreyWolf.
     
    GreyWolf and Cyan like this.