Homebrew [ help] emunand on 2DS without cards

dela

Well-Known Member
OP
Newcomer
Joined
Dec 6, 2014
Messages
78
Trophies
0
Location
Cagliari
XP
122
Country
Italy
Hello guys , I'm looking for help to go on the emunand 2DS , do not own gateway / mt -card . But I would use the emunand mt -card / rednand to upgrade to 9.4 in order to use the eshop . Now I used the launcher of the gateway to backup of the nand . and in order to install the emunand gateway , but the launcher does not allow you to use the card without emunand gateway . Then I thought of extracting the files from MT_INSTALLER.NDS arm7 and arm9 but I can not locate inside the arm9 the part about the opening launcher.dat ps : sorry for my english

Original verios:

Ciao ragazzi, sto cercando aiuto per fare andare la emunand sul 2ds, non posseggo gateway/mt-card. Ma vorrei usare la emunand mt-card/rednand per poter aggiornare alle 9.4 per potere usare l'eshop.
Ora ho usato il launcher della gateway per fare il backup della nella nand. e per poter installare la emunand gateway, ma il launcher non permette di usare la emunand senza la carta gateway.
Allora ho pensato di estrarre dal MT_INSTALLER.NDS i file arm7 e arm9 però non riesco individuare dentro l'arm9 la parte riguardante l'apertura launcher.dat​
 

Attachments

  • MT_installer.zip
    66.1 KB · Views: 163

Sizednochi

Well-Known Member
Member
Joined
Dec 16, 2012
Messages
689
Trophies
0
XP
779
Country
Brazil
I don't think this is possible, no. MT-Card's launcher is encrypted and works only on 4.5, and 2DS can't be downgraded.

We're on the same boat actually.
 

Death78793

What is this, a first person shooter?
Member
Joined
Jan 16, 2015
Messages
251
Trophies
0
Age
27
XP
369
Country
I don't think this is possible, no. MT-Card's launcher is encrypted and works only on 4.5, and 2DS can't be downgraded.

We're on the same boat actually.

Fellow 2DS owner here. I sure would hope there was a way! Being stuck on 9.2 and unwilling to update SysNAND really makes me feel like I should've bought a 3DS/XL.
 

dela

Well-Known Member
OP
Newcomer
Joined
Dec 6, 2014
Messages
78
Trophies
0
Location
Cagliari
XP
122
Country
Italy
I don't think this is possible, no. MT-Card's launcher is encrypted and works only on 4.5, and 2DS can't be downgraded.

We're on the same boat actually.

I know that I can not downgrade to 4.5. For this I thought to be extracted for use arm9 webexploit boot launcher mt -card . But decrypting the arm9 strings I can not find the part about the boot .

o.v:
So che non posso downgradare al 4.5.
Per questo ho pensato di estrare arm9 per usare il webexploit boot launcher mt-card.
Ma anche decriptando l'arm9 in stringhe non riesco a trovare la parte riguardante il boot.
 

nop90

Well-Known Member
Member
Joined
Jan 11, 2014
Messages
1,556
Trophies
0
Location
Rome
XP
2,984
Country
Italy
The payload of the ds hack is not encrypted and you can find the rop chain well explained on pastebin.

I don't remember if it was in the link i send you, but I'll check later.

If you're looking in the code with an hexeditor, you will not see anything. Try to study what is a ropchain and this will be clear to you.

All the code and the string used to load and run the launcher.dat are in the 3DS memory. The string sys:/launcher.dat was found in memory and was used starting from the second char, after remapping mount point of the SDMC with the label ys:.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    AlanMcguffin @ AlanMcguffin: this*