Hacking Question Help a bricked brother out (Advice)

br3compactor

Well-Known Member
Member
Joined
May 1, 2015
Messages
105
Trophies
0
Age
31
XP
136
Country
Brazil
TL/DR: TIFU

I never really used my Switch AT ALL until I got myself my SX PRO.

First thing I did after getting my SX PRO was add an internet connection to my Switch just so that I could register the license (I didn't know there was another way to register). As soon as I finished registering, I deleted the connection. After that, I did a NAND Backup through SX OS 2.0's menu - no games installed, no nothing. Okay. I placed a copy of the backed up NAND stored safe on my computer (and kept another copy on my SD card).

I was reading online about the SX Emunand, and decided to use it to keep my OFW safe and untouched, waiting for a future exploit (I'm on 3.0.2.). I followed this tutorial : https://gbatemp.net/threads/how-to-setup-emunand-keep-sysnand-online.520471/

Since I had added an internet connection to my Switch and was afraid that there could be some sort of ban risk because of that, I decided to go through the steps to "CLEAN SYSNAND".

As I was walking through the steps I came across the same error everytime: Memloaderv2 would never work. Never. Pic for reference (I didn't take this pic, though):

ocSjd0Y.png


Everytime I clicked the line "ums_emmc.ini" it would give me the following message:

"Read 194 bytes from 'ums_emmc.ini', parsing...
Cannot find = separator in kv pair 'XÉMSWIN4.1' on line 0, skipping"

I decided to ask a question about this error on SwitchHacks and on another subreddit, but nobody answered it.

After that, an idea came to me.

Well, if the whole point of using memloader is to mount and modify the NAND straight up though HacDiskMount, why can't I do that to a copy of my NAND backup, then restore the modified NAND backup?

So I did it. I did every step of that to my backup stored inside my SD card, to the letter, then I restored that NAND to my Switch.

Welp. As it turned out, now my Switch would get stuck in an eternal loop of Nintendo logo and Switch logo at boot.

I thought that my SD card might have gotten corrupted somehow and maybe that's why that happened. I decided to format my SD card and put back to my SD my original NAND backup so I could restore it. Afraid that my "corrupted" SD could have any other problems, I only backed up the "save" folder from my SD and the SX PRO files. I left the Nintendo folder to be purged by formatting, since I knew the Switch always makes a Nintendo folder for you.

Then I formatted my SD card, put back the SX PRO files and the "save" folder back to my SD, along with the original NAND backup, run my Switch into RCM to use SX PRO and restore the NAND backup.

As soon as I got finished, I turned it off so I could turn it back on and see if that had worked. As soon as I turned it off I saw the little battery flash in green on the top left corner and I let out a sigh of relief. "It's working, it worked", I thought. But as soon as both logos appeared, and before anything else happened, I'd get an error:

"Error Code: 2002-4153

An error has occurred.

Please press the POWER Button to restart the console. If you are unable to restart the console, hold the POWER Button for 12 seconds to turn the console off.

If the problem persists, refer to the Nintendo Support Website.
support.nintendo.com/switch/error
_____________________________________________________________________________

(X1) [[[my Switch's serial]]]
(X2) [[[my Switch's firmware]]]"

And this error happens regardless of whether I leave the SD card in or not.
I did the restoration again but had no different results.

I want to have hope. I want to believe having my NAND backup will save my Switch, but I don't know what else I can do. Please help me, I need advice!
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
15,931
Trophies
1
Age
27
Location
New York City
XP
10,978
Country
United States
Well instead of using SX OS to restore the NAND, try using Hekate to do it and see if that changes anything. If that doesn't work, I suppose you can try rebuilding majority of the NAND with this tutorial. You should also try rebuilding the GPT which you can find a tool on how to do so here.
 
  • Like
Reactions: Zulnoth and lufeig

Site & Scene News

General chit-chat
Help Users
  • Issac @ Issac:
    You write [ISPOILER]This[/ISPOILER] (or just click the three dots and the mask :P
  • kenenthk @ kenenthk:
    Damn you android
    +1
  • kenenthk @ kenenthk:
    🚔 Will be there asap
  • N10A @ N10A:
    to do what?
  • kenenthk @ kenenthk:
    Force them back to work
  • kenenthk @ kenenthk:
    Get my order or be arrested
  • N10A @ N10A:
    I don't think you can do that in the us
  • N10A @ N10A:
    but yeah funny police like donut joke
  • kenenthk @ kenenthk:
    Now now in the us the police can get away with anything they want to :teach:
  • DinohScene @ DinohScene:
    waste of good donuts, let's roll!
  • N10A @ N10A:
    I mean at the end of the day they would only have to work for like another two weeks at most
  • N10A @ N10A:
    sounds like it sucks there, I would leave too
  • kenenthk @ kenenthk:
    This worker is walking out with stolen donut shoot to kill
  • N10A @ N10A:
    *gets sniped*
    Officer dive rolls to snatch the donut out of the air
    "Don't worry little guy, you're in good hands"
    Proceeds to go beast mode on the donut as crumbs go everywhere
    Gets away with petty theft because
    who's gonna stop you?
  • Something whatever @ Something whatever:
    itsa me crisp ratt .
  • kenenthk @ kenenthk:
    Tonight on CNN police brutality against cooperate donut company
  • N10A @ N10A:
    is that the real crisp ratt?
  • ILeo @ ILeo:
    ps3, can i copy usb files on the multiman menu by pressing triangle then copy onto hhd0>?
  • kenenthk @ kenenthk:
    Should be able to but it's easier to ftp
  • kenenthk @ kenenthk:
    I think L3 activates ftp
  • DinohScene @ DinohScene:
    wasn't FTP enabled by default in multiman?
  • DinohScene @ DinohScene:
    idk it's been so long since I touched that thing
  • kenenthk @ kenenthk:
    Can't remember been a while since I messed with ps3
    kenenthk @ kenenthk: Can't remember been a while since I messed with ps3