1. duong02

    OP duong02 Newbie
    Newcomer

    Joined:
    Feb 15, 2019
    Messages:
    1
    Country:
    Vietnam
    Hello guys,
    I am currently trying to update Project Mirai Dx, but when i press download now, it wil pop up the error code 005-2008, i already tried delete unused tickets, and all other games of mine is update normaly, except for this game, anyone know how to solve this? Thanks.
     
    Last edited by duong02, Feb 15, 2019
    LowEndC likes this.
  2. LowEndC

    LowEndC ǝɹıℲ ɥʇıM ǝɹıℲ ʇɥƃıℲ
    Member

    Joined:
    Jan 25, 2019
    Messages:
    342
    Country:
    Niger
    Oy, so I'm a little late, but i just stumbled across this post.

    the update error for this specific game (USA region) is caused by whomever converted/built that ROM you 'acquired'

    when building a CIA, you have the option of choosing the games major/minor/micro version (major is already set by makerom with HackingToolkit9DS.)

    for instance, if you open FBI>Titles, and hover over a game, you will see it's version, region, titleid etc.

    lets say a games version is 0.1.0
    this means major=0, minor=1, and 0=micro.

    when building a CIA, and at that step where it asks you to choose these values, it also says in parenthesis, (type 0 if you don't know.) the game will still work.
    but if the version doesn't match the official dumps or whats in the eShop, you will get this error.

    the person who made the CIA you have, chose 0 for everything, but if a games version in the eShop is 0.1.0 like Hatsune Miku: Project Mirai DX, the game will think it has an update, and will try to download it, but will always fail at 99%.

    this is because there is no update. 0.1.0 is the initial release, its just the game, no update.
    so it tries to download the whole game, that you never bought, with a fake ticket.
    you installed a "faked-signed' ticket/title, meaning it isn't bought from the eShop and it's ticket isn't signed by Nintendo
    so it knows you didn't buy it, and fails the download, because of the fake ticket.
    basically the incorrect minor/micro version is confusing the system lol
    and you :D

    ==========================================================================================================

    If you can follow simple directions, I will explain how to fix this in detail, its simple. And takes no advanced knowledge. just a few clicks or whatnot :D

    im assuming the game you are talking about is 'Hatsune Miku: Project Mirai DX'? This fix is for that game.

    download 'HackingToolkit9DS' in my attachment included in this post. you need 7-zip to extract this.

    your Mirai CIA must be encrypted, if it's not, which I'm sure it isn't, mine wasn't when i 'acquired' mine,

    put it on your SD card, let's say, at SD:/cias,
    and boot your 3DS up into godmode9,

    find that CIA, select 'CIA Image options', choose 'encrypt file', choose 'encrypt inplace'.

    once that is done, put your SD card back in your PC,

    once you have my attachment extracted to your desktop,

    close out of any programs and don't multi-task,

    move that encrypted CIA to the root of that folder with the 'HackingToolkit9DS.exe' and other files.

    First, run 'SetupUS.exe' and let it do its thing.

    then

    rename the CIA to something short for now, it cant have any spaces or special characters in it's name. example = 1.cia

    then drag and drop the CIA onto 'HackingToolkit9DS.exe'

    the program's cmd window will popup.

    type CE and hit enter to extract the CIA,

    it will ask you the name of the CIA, do not type the extension, if the game's name is 1.cia, type 1

    wait till it's done, and don't have anything open on your computer and don't do a thing until it says it's done. trust me. not even moving your mouse. be patient.

    when it's done, it will confirm and will say type any button to continue. hit enter and close out of it.

    you will have a whole bunch of .bin files and some folders. (exefs/romfs/banner etc.)

    (if you only have the .bin files and the 'extractedmanual' folder, that means your CIA was decrypted, you need to encrypt it with Godmode9 first, then start all over with extracting the CIA, and deleting all other files before doing so.
    so don't waste your time assuming its encrypted, you'll be disappointed.)

    eh, wait ten seconds, cuz I'm weird, and this program runs on ram, and i hate force-shutdowns lol.

    double-click 'HackingToolkit9DS.exe'

    type CR and hit enter to rebuild the CIA

    type in the output name for the CIA, example = NEW (do not type .cia) (the final output name if you type NEW will be NEW_edited.cia)

    after typing the output name and hitting enter,

    it will ask you for a minor version then a micro version respectively

    for 'Hatsune Miku: Project Mirai DX',

    the minor is 1, and the micro is 0 respectively, you don't have to worry about the major version as the program already sets it automatically.

    hit enter and wait till it says its done again. could be 10-15mins for big games, hatsune is 2.2gb

    (Again, in FBI, you will see a titles version i.e. 0.1.0 or major0/minor1/micro0, but for your CIA, it will say 0.0.0 because it was built wrong.)



    and there you go.

    rename 'NEW_edited.cia' back to 'Hatsune Miku: Project Mirai DX.cia'

    put it on your SD card, and install it with FBI, you will see no update message :)

    Source? i did it myself and it worked. :)

    Alternatively, i built this Hack

    https://gbatemp.net/threads/release-hatsune-miku-project-mirai-dx-mix-edition-v1-0.449004/

    and its up at that one place, and has no update error ;)

    ( On a different note, now you know how to build CIA/3DS hacks,

    just extract an encrypted CIA/3DS, drag luma patch files into the extractedromfs folder, and rebuild :D :D :D )
     

    Attached Files:

    Last edited by LowEndC, Apr 10, 2019
  3. Lolithighs

    Lolithighs Newbie
    Newcomer

    Joined:
    Aug 5, 2019
    Messages:
    2
    Country:
    United States
    i followed the steps but everytime the file is only 15KB
     
  4. b1uens0w

    b1uens0w Member
    Newcomer

    Joined:
    Apr 24, 2017
    Messages:
    15
    Country:
    United States
    Extremely informative guide, I can’t appreciate you enough! I was searching around for the correct CIA when I stumbled upon your post. Worked fine for me, thanks man! :D
     
  5. ChriZ220

    ChriZ220 Newbie
    Newcomer

    Joined:
    Mar 19, 2020
    Messages:
    5
    Country:
    Philippines
    Excuse me, it all went well until my rebuilding finished. I don't see a "NEW_edited.CIA" anywhere. How is that? Was it saved in a different directory?

    Edit: Solved it. Made it work for Hatsune Miku Project Mirai. Now I want to try it out for a different game but I don't see a "CIA Image options" for this particular game. It showed up for Hatsune Miku but not for this one. Game is "Ever Oasis"
     
    Last edited by ChriZ220, Mar 24, 2020
  6. wad11656

    wad11656 Advanced Member
    Newcomer

    Joined:
    Jun 18, 2011
    Messages:
    81
    Country:
    United States
    How do I figure out what the minor & micro versions should be for other games with the update error?

    EDIT: FYI - You can't just change the minor and micro version #'s to 9 & 9, in case anyone reading through this was thinking of trying that. Seems the version #'s need to match exactly with the latest version #'s in the eShop (It's not sufficient for the minor & micro #'s to be above the latest version #'s)

    Still wondering how to know the latest minor & micro versions for a game..

     
    Last edited by wad11656, Jun 14, 2020
  7. KazEz

    KazEz Member
    Newcomer

    Joined:
    Jan 4, 2020
    Messages:
    32
    Country:
    Indonesia
    Is My Savedata Still There????
     
  8. lone_wolf323

    lone_wolf323 GBAtemp Psycho!
    Member

    Joined:
    May 27, 2011
    Messages:
    3,358
    Country:
    Canada
    What??? You would want to extract and backup save data with a save manager before doing anything.
     
  9. KazEz

    KazEz Member
    Newcomer

    Joined:
    Jan 4, 2020
    Messages:
    32
    Country:
    Indonesia
    ok
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Hatsune, Project, update