Has the DSTT support gone with the R4?

Discussion in 'DSTT' started by svnelvn, Dec 8, 2008.

  1. svnelvn
    OP

    svnelvn Advanced Member

    Newcomer
    1
    Jun 24, 2008
    United States
    there doesn't seem to be new firmwares anymore, and some games (jedi knight) won't work on it
     
  2. Bri

    Bri GBAtemp Psycho!

    Member
    1
    Dec 25, 2007
    United States
    There was just a firmware update about a week ago (1.16). Unfortunately, it may contain "fake-killer" code that could destroy your flash cart unless you're sure it's a real DSTT. Stick with 1.15 instead (which was released a few weeks prior).

    -Bri
     
  3. glowy

    glowy Advanced Member

    Newcomer
    2
    May 18, 2007
    Netherlands
    A week ago? that firmware is dated 2008-10-30
    And Jedi Knight does not work with this one.
     
  4. juntok_abot

    juntok_abot GBAtemp Regular

    Member
    1
    May 22, 2008
    Indonesia
    most of cart still cannot run jedi knight, i think we'll have to wait a little bit more.
    meanwhile, u can play other game like prince of persian
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice