HANS Black Screen

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by MK7 Fan, Feb 7, 2016.

  1. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Hey! I text edited MK7 a little than re-packaged it into a .romfs, put it in my hans folder at the ROOT of my SD Card, loaded up Hans, and turned on the romfs option. Than loaded it and it cued a black screen with weird looking pixels on the left side. Does anyone know a fix for this??
     
  2. imthe666st

    imthe666st Felyne Hunter

    Member
    355
    166
    Aug 16, 2015
    Germany
    ><HFB>
    Sorry for these general question, but did you repack the romfs correctly? Does it work when you unpack the romfs and then repack it without doing any changes?
     
  3. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Yes it does.
     
  4. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Anyone else have any suggestions?????
     
  5. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    ???
     
  6. ZedMania

    ZedMania Advanced Member

    Newcomer
    82
    9
    Oct 27, 2015
    Heres some stuff that worked for me when this happened:
    -Is the romfs extension .romfs or .bin?
    -Not sure if this applies anymore but have you deleted the 0x1000 bytes in a Hex Editor?
    -Is the romfs the same size as your game? (or at least roughly similar)
    Also since you edited the text, what did you use to edit it? (I know Textedit (mac) tends to screw up the files sometimes - From personal experience)
     
  7. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Thank you for replying, anyway here are some answers:
    The extension is .romfs.
    I didn't delete the bytes because the latest version no longer requires you too, but I can try anyway.
    The .romfs is 100mb, which my original game is 600mb for some reason.
    I used msbt editor, and named some of the tracks stupid things for humor.
     
  8. ZedMania

    ZedMania Advanced Member

    Newcomer
    82
    9
    Oct 27, 2015
    No problem :P I've had problems like this before.

    It seems like the problem is that your romfs is 100 mb. Its supposed to be practically exactly the same size as your original game. From my experience, you'll just have to dump the game again :/ Or if you still have the original unedited romfs, (thats still 600MB) edit that again. Make sure that the ending .romfs is definitely 600Mb or around there. :D
     
    Last edited by ZedMania, Feb 8, 2016
  9. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Ok, I'll try that!
     
  10. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Alroght I redumped, than I patched, my final romfs was 600mb, still black screen. :P
     
  11. ZedMania

    ZedMania Advanced Member

    Newcomer
    82
    9
    Oct 27, 2015
    Awww crap.... uhhh.. I'm really not sure what else would work >.< Have you tried playing around with the different region settings and stuff? Other than that, I have no clue :/ Sorry I couldnt be of more help.
     
  12. MK7 Fan
    OP

    MK7 Fan Member

    Newcomer
    39
    5
    Feb 7, 2016
    United States
    Yes, i've played around, nothing. Thanks anyway!