Going from CFW to OFW

Discussion in 'PSP - Games & Content' started by Tidus755, May 18, 2010.

  1. Tidus755
    OP

    Tidus755 Member

    Newcomer
    11
    0
    Oct 15, 2009
    Canada
    As title says... I recently purchased a few new games and they aren't running on my current 5.00 M33-6 PSP.

    I'm also willing to start playing PsOne Classics but I probably need to have the latest OFW to enter the PS Store... (I've tried a few PSX-PSP games before but they always tend to freeze and become unplayable at some point in the game, which sucks)

    Help is greatly appreciated! Thanks!
     
  2. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Upgrade to 5.50 GEN D3 and they will most likely to run but if you want to go on OFW, just download 6.20 OFW from Sony's site
     
  3. Paarish

    Paarish Connor's Nublet

    Member
    1,719
    605
    Aug 26, 2009
    Married to DinohScene
    Just go to "Network Update" on the PSP
     
  4. Tidus755
    OP

    Tidus755 Member

    Newcomer
    11
    0
    Oct 15, 2009
    Canada
    Won't it brick my PSP? I heard that back in the 3.xx CFW's some people would have their psp's bricked if they just updated through the official network update
     
  5. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    8
    Mar 20, 2010
    Netherlands, currently
    Well there's your problem.

    Anyway, why don't you just use PSPLover and enter PSN while on 5.00m33-6?
     
  6. Tidus755
    OP

    Tidus755 Member

    Newcomer
    11
    0
    Oct 15, 2009
    Canada
    Because I don't really know what PSPLover is [​IMG] Sorry for being a noob loll
     
  7. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Or just completely ignore me.
     
  8. Tidus755
    OP

    Tidus755 Member

    Newcomer
    11
    0
    Oct 15, 2009
    Canada
    I wasn't really ignoring you, my question regarding "updating to 6.20 OFW directly from a CFW" was also referring to your post [​IMG]

    Edit: I guess I'll give it a try then thanks
     
  9. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    8
    Mar 20, 2010
    Netherlands, currently
    Thread is on this page.
     
  10. Roxas6662

    Roxas6662 Newbie

    Newcomer
    6
    0
    Sep 17, 2009
    United States
    download hellcats recovery flasher, and install a clean version of 5.00 if you can, and if you can't, then downgrade to 5.00m33 and then update to 6.20 from sony.
     
  11. Jolan

    Jolan Unlimited Bear Works

    Member
    1,385
    8
    Mar 20, 2010
    Netherlands, currently
    you DO realize you can just flash a clean 5.00 OFW through Hellcat? Right?