genplus roms from usb?

Discussion in 'Wii - Emulation and Homebrew' started by nicknacc, Aug 3, 2009.

Aug 3, 2009

genplus roms from usb? by nicknacc at 10:23 AM (2,303 Views / 0 Likes) 10 replies

  1. nicknacc
    OP

    Newcomer nicknacc Member

    Joined:
    Aug 3, 2009
    Messages:
    14
    Country:
    United States
    first post sup guys. does genplus have the option to read roms from usb yet? could somebody tell them to fix it if they havent?

    oh and is there a better looking gui for snes9x or fce, those things are UGLY. i remember the days when i had a nintendo emulator for my old xbox and that gui was sick with doctor mario picking the games man that was sweet.
     
  2. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    developpers aren't very good graphic designer generally speaking... but I'm sure they would be very happy that you contribute to this open-source project with your awesome artistic talents
     
  3. sl33p

    Member sl33p GBAtemp Regular

    Joined:
    Dec 7, 2008
    Messages:
    191
    Country:
    United States
    Confirming that USB loading works In Genplus. You must have a FAT(32) partition for it to work.
     
  4. dmentd

    Newcomer dmentd Member

    Joined:
    May 13, 2009
    Messages:
    37
    Location:
    Midwest, USA
    Country:
    United States
    I am currently using Genplus Gx 1.3.1 on Wii 4.2U. When I select to read the roms from usb it still chooses SD. All my other emulators play roms from SD just fine. I see this is a issue posted on the genplus google code page, but does anyone have a fix for this? Its obviously working fine for some people. Or maybe its something to do with 4.2?
     
  5. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,125
    Location:
    Belgium
    Country:
    Belgium
    I assume you mean "play roms from USB" here. In other words: that the USB device is detected fine, works, and so on.

    In any case, I used to have this problem as well: both the SMS and genesis emulators kept loading from SD rather than USB where Tantric's emulators (as well as other homebrew) found the USB drive without problems.
    It turned out to be because I had my drive split into 2 partitions. The first being the WBFS-partition, the second one the FAT32. However, since I made the switch to "complete FAT32", it suddenly alowed loading from the USB device without problems. Maybe it also works if it was the other way around (FAT32 being the primary partition, WBFS the secondary), but I don't know.


    NOTE: I'm on 4.0. Besides: HD USB loading isn't supported by nintendo, so I seriously doubt that the firmware version is going to matter.
     
  6. samo

    Newcomer samo Member

    Joined:
    Sep 12, 2009
    Messages:
    17
    Country:
    United States
    Just wanted to chime in, I had a usb partitioned with WFBS and FAT. Gens and SMSplus would not recognize the usb and go straight to the sd selector. I made the FAT the active partition and first drive letter (f for fat and g for wfbs) and it made it work!
     
  7. pedimaisum

    Member pedimaisum GBAtemp Regular

    Joined:
    May 20, 2010
    Messages:
    134
    Country:
    Brazil
    I'm with this problem too. 3 partitions, in that order: wbfs - FAT32 - NTFS

    WBFS y NTFS I make because i'm was a newbie and put all my videos and musics and ntfs. When the WBFS was full, I have to reduce the NTFS and I have created a FAT32. All emulators can see this, but Genplus don't.

    A doubt: This process that you made... You need to format the partitions or I can make this without loose my files? Thanks!
     
  8. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    don't format anything, it's the just the versions you use (the official ones that are on Wiibrew or HBB) are too old, look into this forum for more recent versions
     
  9. mightymuffy

    Member mightymuffy fatbaldpieeater

    Joined:
    Nov 6, 2002
    Messages:
    1,207
    Location:
    Wigan, UK
    Country:
    United Kingdom
    As long as your FAT32 & WBFS drives are primary you should have no problems - like Jacobeian says they're older version and it was a bug - I've got newer versions of both, plus my external HD has 3 partitions, and no problems.... grab the newest version peeps!
    EDIT - nvm, just noticed the dates on most of these posts - oops!
     
  10. pepxl

    Member pepxl GFX W!Z4RD

    Joined:
    Jun 19, 2009
    Messages:
    3,263
    Country:
    United Kingdom
    if using ANY homebrew app your FAT32 must generally be the first partition created on the drive for apps that support USB to be able to see the drive, so, HBC, Emu's, MPlayer CE, WiiMC, USB Loaders all that crap

    3 partitions would be

    FAT32 - NTFS - WBFS

    2 partitions would be

    FAT32 - WBFS

    1 partition

    FAT32

    All set to "Primary" and always set the FAT32 partition to "Active" as only one active partition can be made to a single drive, also you must use a proper partitioning manager like EASEUS that will erase the partition table fully when recreating partitions
     
  11. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,125
    Location:
    Belgium
    Country:
    Belgium
    Grinn...indeed. It's like a blast from the past reading my own post again. [​IMG]


    I have to mention, though, that eke-eke doesn't update his own page often. It's best to check matguitarist's thread for more recent compiled versions of genplus gx. [​IMG]
     

Share This Page