GBA not working on Luma Homebrew.

Discussion in '3DS - Homebrew Development and Emulators' started by Aeriana, Sep 8, 2016.

  1. Aeriana
    OP

    Aeriana Newbie

    Newcomer
    1
    0
    Sep 7, 2016
    United States
    Hello,

    I am so sorry, I know this has been asked again and again; how do I get GBA VC games to work with Luma? At the moment, the screen just goes black when I try.

    I'm using Luma v5.5 with A9LH and BootCTR9 on a O3DS.

    Luma Configuration:

    Autoboot SysNAND.
    SysNAND is updated.
    Force A9LH detection.
    Show current NAND is System Settings.

    I'm not sure what version of BootCTR and A9LH I have; I got my 3DS second hand and everything had already been installed on it.

    I'm not entirely sure how to disable BootCTR9, I edited boot_config to load straight into Luma, and I have arm9bootloader.bin and arm9loaderhax.bin on the root of my SD card, but that didn't work.

    I also tried Pathchanger - I got it from downloading the Luma3DS V6.1.2 folder, but I'm not entirely sure what I should be doing with it? I don't have a Luma.dat file; I have a Luma3DS.bin file which I dropped onto Pathchanger; I tried inputting the path to the Luma3DS.bin file, but that also didn't work. The Luma3DS.bin file is in a folder on the SD card, not on the root like arm9bootloader.bin and arm9loaderhax.bin, not sure if that makes any difference?

    Thanks for any replies, and again sorry to ask about this.
     
  2. osm70

    osm70 GBAtemp Advanced Fan

    Member
    962
    398
    Apr 17, 2011
    Czech Republic
    Do you need BootCTR9 for anything? If not (or if you don't know) try this.

    Rename arm9loaderhax.bin to something else and then rename arm9bootloader.bin to arm9loaderhax.bin and it should work.
     
  3. SimplyFedorable

    SimplyFedorable Evangelion Geek

    Member
    568
    231
    Apr 7, 2016
    United States
    melee hell
    try saltfw if that doesn't work, I used that for the longest time and I fairly sure gba games worked just fine
     
  4. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    3,305
    2,234
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Try using the latest stable version of Luma (6.1.2 I believe).
    Edit: try using luma as arm9loaderhax.bin instead of BootCTR9
     
  5. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    Be sure to enter the full path to luma's bin file, that also includes the file name itself and not just the folder