Gateway - "Card was removed" error

Discussion in '3DS - Flashcards & Custom Firmwares' started by SpaceJump, Sep 26, 2014.

  1. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    Today I suddently get the "The Card was removed" error when starting a game. I ran the diagnostic test with this result:

    - FPGA Test: OK
    - SPI Test: FAIL
    - SPI Read Test: FAIL
    - SD Test: ExFAT

    I never had any problem with my GW card until today. Anything I can do to fix this?
     
  2. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,150
    9,504
    Sep 23, 2013
  3. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    Thanks, I'll give that a try. Which chip excatly is the SPI chip? The small black one? Where exactly does the pressure on the card have to go?
     
  4. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,150
    9,504
    Sep 23, 2013
    well i would suggest you try popping the card in and out a few times first, just to make sure its not a contact issue, but the video shows you where to put the padding
     
  5. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    To be honest I don't see exactly where the pressure has to go in the video. I tried a tape like you did all over the card, but that didn't work. Which one is the SPI chip?
     
  6. JaapDaniels

    JaapDaniels GBAtemp Fan

    Member
    361
    66
    Apr 22, 2012
    Netherlands
    so if i'm right, the contacts need to be cleaned, if possible resolder them, but watch out for the plastic. since i noticed its the contacts with the 3ds... take a flashlight to check if the connector inside your 3ds looks okay (had some consoles where the pins were bend)

    you need the tape to stabilize the card so the contacts are pressed agains each other... like i said it's a contact failure most likely clean the contacts with contact spray, check the connector inside the 3ds and your card.
     
  7. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    I got it to work with paper on the back of the card, but when I tape the back like in the video, the SPI fails again.
     
  8. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,150
    9,504
    Sep 23, 2013
    might be a loose connection by the FPGA then, thats on the opposite side of the card, just do whatever works for you
     
  9. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    No, the FPGA passes the diagnostics test, it's the SPI that fails.
     
  10. JaapDaniels

    JaapDaniels GBAtemp Fan

    Member
    361
    66
    Apr 22, 2012
    Netherlands
    what i've noticed is that the test is not really testing what it says it test the communication between spi and 3ds. that's why in the video he uses tape and cleans the contacts... the spi might just work fine the contact are degraded most likely by changing the card too much.
     
  11. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    214
    Aug 18, 2005
    Gambia, The
    Zebes
    I'm very sure in my case it's the SPI because the GW card is always recognized and the ROMs always show up. Games that save on the NAND even work, because I guess they don't use the save chip at all.